[Browser]Long press a link, the "Open in new private window" is displayed with truncation.

VERIFIED FIXED

Status

Mozilla Localizations
ru / Russian
VERIFIED FIXED
3 years ago
2 years ago

People

(Reporter: Lancy(Leave from Mozilla), Assigned: Alexander L. Slovesnik)

Tracking

(Blocks: 1 bug)

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 verified)

Details

(Whiteboard: LocRun2.2)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Browser][Flamev2.2]Search the keyword and long press a link in the search result view, the "Open in new private window" is displayed with truncation.
See attachment:Russian_Open in new private window.png

[2.Testing Steps]: 
1.Set your phone language to Russian and connect the network.
2.Launch Browser and search the keywords.
3.Long press a link in the search result view.

[3.Expected Result]: 
3.The "Open in new private window" should not be displayed with truncation.

[4.Actual Result]: 
3.The "Open in new private window" is displayed with truncation.

[5.Reproduction build]: 
Device: Flame 2.2 user (Affected)
Build ID               20150504002502
Gaia Revision          8d14361337e608c8cdf165ea5034db5eda23b618
Gaia Date              2015-05-01 18:23:46
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/cb7cb6597c91
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150504.041541
Firmware Date          Mon May  4 04:15:53 EDT 2015
Bootloader             L1TC000118D0

[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test

[8.Note]:
1.This function dose not exist in Flame 2.1 user build.
2.This issue does NOT exist in Spanish, Serbian Cyrillic,Serbian Latin, Bengali from India, Basque, Arabic, Portuguese from Brazil and Portuguese from Portugal.
This issue still exist in Polish&Greek and it should file under Mozilla Localizations.
(Reporter)

Comment 1

3 years ago
Created attachment 8601397 [details]
Russian_Open in new private window.png
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
See Also: → bug 1161466, bug 1161474
What about 2.1?
Flags: needinfo?(yulan.zhu)
Oh not present in 2.1.
Flags: needinfo?(yulan.zhu)
Whats the process for such bugs? Trying to get a shorter translation?
Flags: needinfo?(lebedel.delphine)
Yes since this is a new string, let's first see if localizer can find a way to shorten it (either abbreviating or dropping some words out, as long as it still makes sense). I see other cases where locales are affected on the same string, so this might end up needing a shorter string or a dev fix. 
But usual process for these is 1st we see if localizers can shorten the string.
Putting under Mozilla Localization component for Russian, flagging localizer
Component: Gaia::Browser → ru / Russian
Flags: needinfo?(lebedel.delphine) → needinfo?(unghost)
Product: Firefox OS → Mozilla Localizations
(Assignee)

Comment 6

3 years ago
Fixed in http://hg.mozilla.org/gaia-l10n/ru/rev/eaa9f55d6ada
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(unghost)
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Assignee: nobody → unghost
(Reporter)

Comment 7

3 years ago
Created attachment 8603925 [details]
Verify1_Russian_Open in new private window_Pass.png

According to the STR in comment 0, this issue is verified pass on latest flame 2.2 user build.

See attachment:Verify1_Russian_Open in new private window_Pass.png
Reproducing rate:0/10

Device: Flame 2.2 user (Pass)
Build ID               20150510002505
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.043421
Firmware Date          Sun May 10 04:34:32 EDT 2015
Bootloader             L1TC000118D0
(Reporter)

Updated

3 years ago
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+]
status-b2g-v2.2: affected → verified
(Reporter)

Updated

2 years ago
QA Whiteboard: [MGSEI-Triage+] → [MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F → LocRun2.2
You need to log in before you can comment on or make changes to this bug.