[Music] [Front-end] Separate the ui into independent views

RESOLVED FIXED in FxOS-S4 (07Aug)

Status

RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: dkuo, Assigned: justindarc)

Tracking

unspecified
FxOS-S4 (07Aug)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(feature-b2g:2.5+)

Details

(Whiteboard: [NG Gaia Music])

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
To fit the new gaia architecture, we need to separate the ui into independent views, each view should have its own js, css and html files, then put them into the view folder structure.
(Reporter)

Updated

4 years ago
Whiteboard: [NG Gaia Music]

Updated

4 years ago
Assignee: nobody → jdarcangelo
Target Milestone: --- → FxOS-S3 (24Jul)

Updated

4 years ago
Duplicate of this bug: 1012613
(Assignee)

Updated

4 years ago
Target Milestone: FxOS-S3 (24Jul) → FxOS-S4 (07Aug)

Updated

3 years ago
feature-b2g: --- → 2.5+
Created attachment 8646578 [details] [review]
[gaia] justindarc:bug1161497 > mozilla-b2g:master
(Assignee)

Comment 3

3 years ago
Comment on attachment 8646578 [details] [review]
[gaia] justindarc:bug1161497 > mozilla-b2g:master

MegaPatch (TM)
Attachment #8646578 - Flags: review?(squibblyflabbetydoo)
Comment on attachment 8646578 [details] [review]
[gaia] justindarc:bug1161497 > mozilla-b2g:master

rs=me. Granted, I really only looked at the manifest to make sure it's sane. For everything else, we'll probably be gradually fixing it up and adding to it as needed, anyway.
Attachment #8646578 - Flags: review?(squibblyflabbetydoo) → review+
(Assignee)

Comment 5

3 years ago
Landed (in dev_apps) on master:

https://github.com/mozilla-b2g/gaia/commit/d0b431ee99feb8d312f7388c0c62294b3abfd12b
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.