Content shifted when removing secondary monitor

RESOLVED WORKSFORME

Status

()

Firefox
Untriaged
RESOLVED WORKSFORME
3 years ago
2 years ago

People

(Reporter: ashughes, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8601472 [details]
Screen Shot 2015-05-05 at 9.39.43 AM.png

Yesterday I was working from a hotel desk at the Toronto office with a secondary monitor using my Macbook Pro 13". When I started the day I had a single Firefox window open with a few tabs set to my full window size (not full screen) on my Macbook. When connecting the secondary monitor I dragged the Firefox window over and made it occupy half the space (tiled horizontally). 

At the end of the day I unplugged the secondary monitor and the Firefox window automatically popped back to occupy full window space on my laptop screen. The result was the active tab's content was shifted to the right. Reloading the tab corrected the issue.

Note: This was with Firefox 40.0a1 on Mac OS 10.10.3

I suspect this could be something to do with the changing resolutions and dpi settings as the window moves from screen to screen.
(Reporter)

Updated

3 years ago
OS: Unspecified → Mac OS X
Hardware: Unspecified → All
Hi Anthony,

I have tried to test this on latest Firefox release (43.0.3) and latest Nightly build (46.0a1-20151223140742) and could not reproduce it. When I disconnected the second monitor, the browser was correctly moved to the main screen and the content of the focused tab was correctly displayed. 
Indeed I have used a Mac Mini PC connected at two 22 inch Full HD monitors to test this.

Mozilla/5.0 (Macintosh; Intel Mac OS X 10.10; rv:43.0) Gecko/20100101 Firefox/43.0

Since I don't have a Mac Book to reproduce your environment, can you please test this using the latest Firefox release and/or latest Nightly build (https://nightly.mozilla.org/) and let me know if it still occurs to you ?

Thanks,
Paul
Flags: needinfo?(anthony.s.hughes)
(Reporter)

Comment 2

2 years ago
No longer reproduces.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(anthony.s.hughes)
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.