[Browser][Panning and Zooming] The overscroll effect will happen while scrolling in the middle of a page in the browser app

VERIFIED FIXED in Firefox 41

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: dharris, Assigned: mtseng)

Tracking

({regression})

unspecified
mozilla41
ARM
Gonk (Firefox OS)
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.5+, firefox39 wontfix, firefox40 wontfix, firefox41 fixed, b2g-v2.2 unaffected, b2g-master verified)

Details

(Whiteboard: [3.0-Daily-Testing][systemsfe], )

Attachments

(2 attachments)

Description:
While the user is zoomed into a page, or on a page with a large area of scrolling space, the page will exhibit overscroll behavior in the middle of an app while scrolling.


Repro Steps:
1) Update a Flame to 20150505010204
2) Open Browser> Navigate to google.com
3) Search something such as "Mozilla"
4) Zoom all the way in> Scroll/Pan around


Actual:
Panning or scrolling on any zoomed in webpage will show the overscroll effect mid scroll


Expected:
The overscroll effect only shows at the top or bottom of a page/screen

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150505010204
Gaia: 70077825aab2c7a79611befb40a5fe7e610d5443
Gecko: 102d0e9aa9e1
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (3.0)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


Repro frequency: 10/10
See attached: Logcat, Video - https://youtu.be/2UYXkV-tjP4
This issue does NOT occur on Flame 2.2

The overscroll effect only shows at the top or bottom of a page/screen

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150505002501
Gaia: 772a9491909abd02dc67278dd453746e2dd358a8
Gecko: 2df83538ae20
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
[Blocking Requested - why for this release]: bad user experience, is a regression
blocking-b2g: --- → 3.0?
QA Contact: jmercado
blocking-b2g: 3.0? → 3.0+
The changes for Bug 1156636 seem to have caused this issue.

B2g-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150504001102
Gaia: e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gecko: 8e1f05ac1281
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150504024002
Gaia: e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gecko: c9073aaaf9a6
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working gaia / First Broken gecko - 
Gaia: e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gecko: c9073aaaf9a6

First Broken gaia / Last Working gecko - 
Gaia: e18cce173840d6ff07fb6f1f0e0ffb58b99aab3e
Gecko: 8e1f05ac1281

Gecko Pushlog: http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=8e1f05ac1281&tochange=c9073aaaf9a6
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(pbylenga)
checking.
Assignee: nobody → mtseng
Status: NEW → ASSIGNED
Flags: needinfo?(mtseng)
We cannot exclude post scale from mParameters.mX/YScale because in painted layer, mParameters.mX/YScale is not represent post scale. So I exclude it from layer.GetTransform().
Attachment #8602576 - Flags: review?(roc)
https://hg.mozilla.org/mozilla-central/rev/6afb088b0cff
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
This issue is verified fixed on the latest 3.0 Nightly Flame build.  

Actual Results: The browser does not overscroll in the middle of pages when zoomed.  It does correctly overscroll at the top and bottom of the page.

Environmental Variables:
Device: Flame 3.0 KK (Full Flash) (319 MB)
BuildID: 20150528010203
Gaia: 05380df3158fa39e1dde1687c0bf11a71f8c6868
Gecko: baa9c64fea6f
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage+] → [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
You need to log in before you can comment on or make changes to this bug.