Status

()

RESOLVED DUPLICATE of bug 69000
17 years ago
6 years ago

People

(Reporter: jayvdb, Assigned: endico)

Tracking

Details

Attachments

(2 attachments)

(Reporter)

Description

17 years ago
Global named queries would be set up by the Bugzilla administrator, and
available to all users.

Typical queries that would be set up in this way include:
- queries that are common between users.
- queries that new developers/users wish they knew how to run.

Additional benefits:
- As these queries could be loaded into query.cgi, it would assist new Bugzilla
users learn how to use the more advanced features of query.cgi
- As stored queries are globally accessible, their names can be used for links.
e.g. The Release Blockers link on the bugzilla/mozilla roadmaps could be changed
from holding a query string to a stored query name, and the query string could
be changed after each release.
(Reporter)

Comment 1

17 years ago
Created attachment 62321 [details] [diff] [review]
v0.1

allows anyone to store a global query with userid=0
(Reporter)

Comment 2

17 years ago
Created attachment 62323 [details] [diff] [review]
querylist.cgi - Lists global queries with link to query and buglist

Just a quick attempt to get them working.  This list would get long, and thus
they would get annoying in the footer/sidebar.	Perhaps another table is
warranted, allowing users to select global queries to be placed in the
footer/sidebar.

*** This bug has been marked as a duplicate of 69000 ***
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE
QA Contact: matty_is_a_geek → default-qa
You need to log in before you can comment on or make changes to this bug.