Closed Bug 1161771 Opened 6 years ago Closed 2 years ago

Don't treat flex items as having definite main sizes unless flex container has definite main size

Categories

(Core :: Layout, defect)

defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1092007
Tracking Status
firefox40 --- affected

People

(Reporter: dholbert, Unassigned)

References

(Blocks 1 open bug, )

Details

Attachments

(1 file)

Attached file testcase 1
Spec change:
 https://hg.csswg.org/drafts/rev/8e208f535b2e

Updated spec text (with addition emphasized using "__"):
 # If a percentage is going to be resolved against a flex item’s main size,
 # and the flex item has a definite flex basis,
 # __and the flex container has a definite main size,__
 # the flex item’s main size must be treated as definite
 # for the purpose of resolving the percentage, and the
 # percentage must resolve against the flexed main size
 # of the flex item (that is, after the layout algorithm
 # below has been completed for the flex item’s flex
 # container, and the flex item has acquired its final size).

Testcase attached. It shows we match the spec text as it stood *before* this tweak. We need to change to match the updated spec-text.
Depends on: 1128354
See Also: → 1092007
Duplicate of this bug: 1383692
With the spec having changed again, I think this is now a dupe of 1092007?
Yeah, basically.
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1092007
You need to log in before you can comment on or make changes to this bug.