document content not scaling correctly

RESOLVED INVALID

Status

()

Core
Graphics
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: Nika, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [gfx-noted])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8601764 [details]
Retina -> Non-Retina tiny document problem

When moving the nightly browser between a retina and non-retina display, occasionally the document content doesn't rescale correctly. This is not consistent, and I haven't found a way to reliably reproduce it, but I've seen the following effects:

Non-Retina => Retina:
 - Tiny text, the text content renders as though it was scaled to 50%
 - Oversized document, only the upper left corner of the apparent view area is visible, the rest is obscured (as though window was twice as big as it actually is

Retina => Non-Retina:
 - Tiny document, the document only fills a quarter of the area which it should fill

(I haven't seen giant text stick around, although I see it during the resize as I move the window)

I've attached an image of the Retina => Non-Retina problem, and can attach more screenshots as I notice them.
:mystor, does the problem still happen? I tried the STR, but I did not see the problem.
Flags: needinfo?(michael)
Whiteboard: [gfx-noted]
(Reporter)

Comment 2

3 years ago
(In reply to Sotaro Ikeda [:sotaro] from comment #1)
> :mystor, does the problem still happen? I tried the STR, but I did not see
> the problem.

I'm not sure, I haven't had my laptop hooked up to an external monitor since last summer when I was in the office - so I haven't been using the browser in an environment where the scaling problems might come up. I also don't have a monitor around for me to test it on. Sorry.
Flags: needinfo?(michael)
Thanks. I tested the STR with 2 external monitors, but I did not see the problem. I am going to close the bug now. Please reopen it, when you sees the problem again.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.