Create an "edit site listing" form

VERIFIED FIXED in 2015-07-14

Status

P3
enhancement
VERIFIED FIXED
4 years ago
3 years ago

People

(Reporter: ddurst, Assigned: robhudson)

Tracking

2015-07-14
Points:
---
Dependency tree / graph

Details

The lookup tool should link to a page that allows admins to edit a listing of a site.

Seems like the path of least resistance is to extend the existing dev tools (for now)?
Severity: normal → enhancement
Priority: -- → P1

Updated

4 years ago
Blocks: 1165024

Updated

4 years ago
No longer blocks: 1165024
Since Websites have no author, maybe it's simpler to just create a form and use it in the lookup tool, and then refactor that for phase 1.

Updated

4 years ago
Depends on: 1161865
(Assignee)

Updated

3 years ago
Assignee: nobody → robhudson.mozbugs
(Assignee)

Updated

3 years ago
Depends on: 1174253
(Assignee)

Comment 2

3 years ago
https://github.com/mozilla/zamboni/commit/e3818e9 

The edit form is linked to from the website search in the lookup tool.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Target Milestone: --- → 2015-06-30

Comment 3

3 years ago
The form is created but there are some issues:
1. When editing a website details (I have used: https://marketplace-dev.allizom.org/lookup/website/8512/edit) When trying to modify the name there are some warnings displayed. Even if you do not modify anything in the form the same warnings are displayed: http://screencast.com/t/ftAE6CY8

2. The admin can't change the icon from that form. Should't we have the option to upload a custom icon?

3. There is a confusing message about tags. The website already have those tags saved but when trying to remove one it says that you have too many: http://screencast.com/t/wDlVAmdvEQ

@Rob What is your opinion on the above issues.
Flags: needinfo?(robhudson.mozbugs)
(Assignee)

Comment 4

3 years ago
(In reply to Madalin Cotetiu from comment #3)
> The form is created but there are some issues:
> 1. When editing a website details (I have used:
> https://marketplace-dev.allizom.org/lookup/website/8512/edit) When trying to
> modify the name there are some warnings displayed. Even if you do not modify
> anything in the form the same warnings are displayed:
> http://screencast.com/t/ftAE6CY8

Yes, this looks like a bug. The default locale is "it" and that is what you have values for. I'll have to see why it is requiring 'en-us'.

> 2. The admin can't change the icon from that form. Should't we have the
> option to upload a custom icon?

That was undefined. I'll check in to see if we want/need this functionality for this phase.

> 3. There is a confusing message about tags. The website already have those
> tags saved but when trying to remove one it says that you have too many:
> http://screencast.com/t/wDlVAmdvEQ

It looks like the import script didn't check the keywords in the same way that this form is so it is now finding this error? We'll need to either update the import script to also do this or relax the form.

Excellent QA, thanks.
Flags: needinfo?(robhudson.mozbugs)

Comment 5

3 years ago
Reopening the bug until the above issue are fixed.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Priority: P1 → P3

Comment 6

3 years ago
In Lookup Tools->Websites->Edit Listing page:
1. The Cancel option, is not working: http://screencast.com/t/irOGU53M5br
2. The message displayed when trying to save changes without completing the mandatory fields, like Name or Description, is a bit confusing: http://screencast.com/t/TsTXOYmHY9m
(Assignee)

Comment 8

3 years ago
https://github.com/mozilla/zamboni/pull/3165

I increased the keywords limit to 100 (default is 20).

We aren't adding an icon edit option at this time.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Assignee)

Updated

3 years ago
Target Milestone: 2015-06-30 → 2015-07-07
(Assignee)

Updated

3 years ago
Target Milestone: 2015-07-07 → 2015-07-14

Comment 9

3 years ago
Verified as fixed in FF42(Win7)
The issues from comment 3 and comment 6 are no longer reproducing.
Closing bug.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.