Closed Bug 1161925 Opened 5 years ago Closed 2 years ago

[Camera]When you share the picture in preview page, the picture can't be rotated.

Categories

(Firefox OS Graveyard :: Gaia::Camera, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:-, b2g-v2.2 affected, b2g-master affected)

RESOLVED WONTFIX
blocking-b2g -
Tracking Status
b2g-v2.2 --- affected
b2g-master --- affected

People

(Reporter: wangxin, Assigned: dmarcos, NeedInfo)

References

Details

(Whiteboard: [v2.2-nexus-5-l])

Attachments

(3 files)

[1.Description]:
[Nexus 5][v2.2&3.0][Flame][v2.2&3.0][Camera]When you share the picture in preview page,then back to preview, the picture can't be rotated successfully.
See log:"logcat_0521.txt"
See video:"0521.mp4"
Found time:05:21

[2.Testing Steps]: 
1. Launch "Camera".
2. Take a picture.
3. Tap  the thumbnail to invoke  preview page.
4.  Rotate  device.
5. Tap the "share" icon in top-right.
6.  Choose one of the item to share this picture(I use Wallpaper)
7. Then "Set" or "Cancel" it to back to Preview page. 
8. Rotate device.

[3.Expected Result]: 
8. The device should be rotated successfully.

[4.Actual Result]: 
4. The device can be rotate successfully.
8. The device can't be rotate.

[5.Reproduction build]: 
FLame 2.2(Affected):
Build ID               20150505002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2df83538ae20
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.041743
Firmware Date          Tue May  5 04:18:00 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Affected):
Build ID               20150505010204
Gaia Revision          70077825aab2c7a79611befb40a5fe7e610d5443
Gaia Date              2015-05-04 18:09:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/102d0e9aa9e1
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.043622
Firmware Date          Tue May  5 04:36:34 EDT 2015
Bootloader             L1TC000118D0

Nexus5_ 2.2(Affected) :

Build ID               20150505002501

Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8

Gaia Date              2015-05-05 02:02:24

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2df83538ae20

Gecko Version          37.0

Device Name            hammerhead

Firmware(Release)      5.1

Firmware(Incremental)  eng.cltbld.20150505.041235

Firmware Date          Tue May  5 04:12:53 EDT 2015

Bootloader             HHZ12f

Nexus5_3.0(Affected):
Build ID               20150505160203
Gaia Revision          42dc5f02a9df006b129824cd9bffa93cab937ab2
Gaia Date              2015-05-05 11:06:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5907a8eca521
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150505.192812
Firmware Date          Tue May  5 19:28:29 EDT 2015
Bootloader             HHZ12f
[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
Attached video Bug log: 0521.mp4
Check with UX for correct behavior. Hi Tiffanie, we need your comment here, thank you.
Flags: needinfo?(tshakespeare)
In the video, it looks like the preview was rotating before launching the share activity, but cancelling out of the share activity the rotation stops working - is that the sum of it?

That's definitely a bug; the photo should always rotate with device rotation in preview.

Thanks Eric! :)
Flags: needinfo?(tshakespeare)
[Blocking Requested - why for this release]: broken functionality.
Per comment #3, set 3.0?
blocking-b2g: --- → 3.0?
blocking-b2g: 3.0? → 3.0+
See Also: → 1182557
Diego, 

Seeing a bunch of camera bugs, please help fixes it. Thanks!

Hema
Assignee: nobody → dmarcos
Diego, 

Please take a look at this first. Marking this P1 for broken function. 

Thanks
Hema
Flags: needinfo?(dmarcos)
Priority: -- → P1
I cannot reproduce this anymore on:

Build ID               20150903030230
Gaia Revision          29f363d6236bf7db8141d7a1f1185a1dcd809bf7
Gaia Date              2015-09-02 17:52:11
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/a6786bf8d71d4cf40c3d40e06d8e3c9866863475

Can you still see this issue?
Flags: needinfo?(dmarcos) → needinfo?(wangxin)
Hi Diego,
The phenomenon has been modified on v3.0, but this bug still exists on v2.2  now.

On 3.0, the behaviour is that after you cancel sharing, device goes to viewfinder. However on 2.2, after cancelling, it still stays at preview screen which can not be rotated.

Flame 2.2(Affected):
Build ID               20150905032501
Gaia Revision          335cd8e79c20f8d8e93a6efc9b97cc0ec17b5a46
Gaia Date              2015-08-14 19:06:41
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/d3cb4f28c735
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150905.065255
Firmware Date          Sat Sep  5 06:53:06 EDT 2015
Firmware Version       v18D v4
Bootloader             L1TC000118D0

Flame 2.5:
Build ID               20150905112803
Gaia Revision          03be7d8918bed58c92a40bba211bbbc97a0e516a
Gaia Date              2015-09-04 11:56:30
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/139446daedab3d00b9f0faba25e1e82191c8c8d1
Gecko Version          43.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20150905.105729
Firmware Date          Sat Sep  5 10:57:37 UTC 2015
Firmware Version       v18D v4
Bootloader             s1
Flags: needinfo?(wangxin) → needinfo?(dmarcos)
QA Whiteboard: [MGSEI-Triage+]
On master this issue cannot be reproduced. Removing this from 2.5 release blocker.
blocking-b2g: 2.5+ → -
Priority: P1 → --
Hi Hema,
I can repro this bug on latest Aries master by flowing STR.
STR:
1. Launch Camera.
2. Take a picture.
3. Tap  the thumbnail to invoke  preview page.
4. Rotate  device.
5. Tap the "share" icon in top-right.
6. Back to preview page, try to Rotate device again.

Actual result:
6. The device can't be rotate.

Repro rate: 5/5
See log:"logcat_2329.txt"
Found Time:23:29

Aries KK master(Affected):
Build ID               20151209233610
Gaia Revision          961528f4391668bc89ec0be14fa367cea099b588
Gaia Date              2015-12-08 18:11:20
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/b40ba117fa757861c9caa660ae989122718b494b
Gecko Version          45.0a1
Device Name            aries
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.worker.20151209.225602
Firmware Date          Wed Dec  9 22:56:09 UTC 2015
Bootloader             s1
Flags: needinfo?(hkoka)
Diego, could you please check again on master
Flags: needinfo?(hkoka)
Firefox OS is not being worked on
Status: NEW → RESOLVED
Closed: 2 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.