[Contacts]If we import contact with birthday in January from outlook, the birthday field will be missing.

VERIFIED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::Contacts
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Verson Xiong (Leave from Mozilla), Assigned: arcturus)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: 2.2-nexus-5-l])

Attachments

(4 attachments)

(Reporter)

Description

3 years ago
Created attachment 8602021 [details]
0907.png

[1.Description]:
[Flame v2.2 & v3.0][Nexus 5 v2.2 & v3.0][Contacts]Import the outlook contact whose birthday is in January. When we check this imported contact, we can find there is no birthday field in contact details.
Found time:09:07
See attachment:logcat_0907.txt,0907.png & video_0907.txt 

[2.Testing Steps]: 
Prerequisite:There is a contact whose birthday is in January in outlook account.
1. Launch Contact.
2. Tap Settings->"Import Contacts", select Outlook.
3. login Outlook, import contact with birthday in January to device.
4. Check the contact you imported.

[3.Expected Result]: 
4.Birthday field will not be missing.

[4.Actual Result]: 
4.Birthday field is missing.

[5.Reproduction build]: 
Flame 2.2 (affected)
Build ID               20150505002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2df83538ae20
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.041743
Firmware Date          Tue May  5 04:18:00 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 (affected)
Build ID               20150505010204
Gaia Revision          70077825aab2c7a79611befb40a5fe7e610d5443
Gaia Date              2015-05-04 18:09:33
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/102d0e9aa9e1
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150505.043622
Firmware Date          Tue May  5 04:36:34 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2 (affected)
Build ID               20150505002501

Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8

Gaia Date              2015-05-05 02:02:24

Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/2df83538ae20

Gecko Version          37.0

Device Name            hammerhead

Firmware(Release)      5.1

Firmware(Incremental)  eng.cltbld.20150505.041235

Firmware Date          Tue May  5 04:12:53 EDT 2015

Bootloader             HHZ12f

Nexus5 3.0 (affected)
Build ID               20150505160203
Gaia Revision          42dc5f02a9df006b129824cd9bffa93cab937ab2
Gaia Date              2015-05-05 11:06:17
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5907a8eca521
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150505.192812
Firmware Date          Tue May  5 19:28:29 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8602022 [details]
lotcat_0907.txt
(Reporter)

Comment 2

3 years ago
Created attachment 8602023 [details]
video_0907.mp4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
The dates in Outlook import was supposed to be fixed in bug 1140329. 

[Blocking Requested - why for this release]: Regression on a standard use case.
blocking-b2g: --- → 2.2?
Keywords: regression
See Also: → bug 1140329
Triage meeting: blocking on basic use case.
blocking-b2g: 2.2? → 2.2+
Assignee: nobody → francisco
Status: NEW → ASSIGNED
Created attachment 8602775 [details] [review]
[gaia] arcturus:bug-1161975 > mozilla-b2g:master
Attachment #8602775 - Flags: review?(ferjmoreno)
Attachment #8602775 - Flags: review?(ferjmoreno) → review+
Keywords: checkin-needed

Updated

3 years ago
Keywords: checkin-needed
https://github.com/mozilla-b2g/gaia/pull/29950

Autolander could not land the pull request due to not having collaborator rights. This is possibly due to a tree closure. Please check the tree status and request checkin again once the tree is open.
Landed:

https://github.com/mozilla-b2g/gaia/commit/47d1738639afaf723dcbd6f74502fc848a7e35e1
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
Comment on attachment 8602775 [details] [review]
[gaia] arcturus:bug-1161975 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
Always been there
[User impact] if declined:
Data loss
[Testing completed]:
Tested on master
[Risk to taking this patch] (and alternatives if risky):
Pretty low
[String changes made]:
None
Attachment #8602775 - Flags: approval-gaia-v2.2?

Updated

3 years ago
status-b2g-master: affected → fixed

Comment 9

3 years ago
Comment on attachment 8602775 [details] [review]
[gaia] arcturus:bug-1161975 > mozilla-b2g:master

Approving the patch and request QA verify when land on 2.2
Flags: needinfo?(fan.luo)
Attachment #8602775 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/8806bed740552c52293d2fbd50d50f62a7409531
status-b2g-v2.2: affected → fixed
Target Milestone: --- → 2.2 S12 (15may)
This issue is verified fixed on Flame 3.0 and 2.2. Outlook contacts with birthdays in January are displayed after importing. Birth years are NOT displayed, which according to bug 1140329 comment 19, is expected behavior.

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150513010202
Gaia: 0d6c04f13fd385bda045f4e539b2a67cb5d84b1d
Gecko: 62d9b117c688
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 41.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:41.0) Gecko/41.0 Firefox/41.0

Device: Flame (KK, full flashed, 319MB)
BuildID: 20150513002507
Gaia: e048df68f6f4853b5826a8816e143d95258149de
Gecko: 0e6b4aab2b94
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
Status: RESOLVED → VERIFIED
QA Whiteboard: [QAnalyst-Triage?]
status-b2g-v2.2: fixed → verified
status-b2g-master: fixed → verified
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
Flags: needinfo?(fan.luo)
You need to log in before you can comment on or make changes to this bug.