If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

crash in nsJAR::ReadLine(char const**)

RESOLVED WORKSFORME

Status

()

Firefox
General
--
critical
RESOLVED WORKSFORME
2 years ago
2 years ago

People

(Reporter: vasilica_mihasca, Unassigned)

Tracking

({crash})

28 Branch
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

This bug was filed from the Socorro interface and is 
report bp-2ec69a4b-dfdf-4cb4-8f57-35d942150506.
=============================================================

STR:
1.Launch Firefox with a clean profile.
2.Navigate to: https://addons-dev.allizom.org/en-US/firefox/addon/adblock-plus/?src=cb-dl-users
3.Click "Add to Firefox" green button

Additional notes:
- Ran into this on Ubuntu 14.04 32 bit, using Firefox 28 (build ID: 20140314220517)
- This crash is also reproducible on Firefox 28 using:
       *Windows 8.1 32bit: https://crash-stats.mozilla.com/report/index/2e478d2d-a812-43b0-98c2-003f42150506
       *Mac OS X 10.9.5: https://crash-stats.mozilla.com/report/index/0267a360-4a71-440e-91c7-161da2150506
The first affected version is Firefox 23 (build ID: 20130730113002)
  - Ubuntu 14.04 32-bit: https://crash-stats.mozilla.com/report/index/9ca7b041-84e2-47d2-8471-9bf4f2150506
  - Windows 8.1 32bit: https://crash-stats.mozilla.com/report/index/fe0bbd44-896b-4340-aaaa-1ffdf2150506
  - Mac OS X 10.9.5: https://crash-stats.mozilla.com/report/index/599bfd64-1dd1-4d13-ab09-ee8ad2150506

- I also encountered this issue on Firefox 24.
- This crash is reproducible only for Adblock Plus add-on.
I can't reproduce this on Firefox 28 on OSX. This crash looks like the crash that was happening before bug 1158938 was fixed. Did you try clearing your cache first? Maybe adblock plus only recently got resigned on dev with the new code or something.
adblock-plus was one of the early add-ons we signed on -dev. I've unsigned and resigned it on -dev just to make sure we are signing with the fixes in bug 1158938. You could also try out https://addons.allizom.org/en-US/firefox/addon/adblock-plus/ (stage instance).
I have tested again today and I was unable to reproduce the crashes. Adblock Plus add-on was successfully installed. 

Verified on Firefox 23, Firefox 24 and Firefox 28 using Windows 8.1 32-bit, Ubuntu 14.04 32-bit and Mac OS X 10.9.5.

Updated

2 years ago
Crash Signature: [@ nsJAR::ReadLine(char const**)] → [@ nsJAR::ReadLine(char const**)] [@ nsJAR::ReadLine]

Comment 5

2 years ago
Considering there are none of these reports in crash-stats that I can see, and 28 is aaaaancient now, and per comment #4, going to close this as WFM.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.