Test failure 'Current URL should be identical to the target URL' in testSafeBrowsingWarningPages.js

RESOLVED FIXED in mozilla40

Status

Mozilla QA
Mozmill Tests
RESOLVED FIXED
2 years ago
2 years ago

People

(Reporter: whimboo, Assigned: whimboo)

Tracking

({regression})

unspecified
mozilla40
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [mozmill-test-failure])

Attachments

(1 attachment)

(Assignee)

Description

2 years ago
We are currently failing in this test with:

Current URL should be identical to the target URL - expected https://support.mozilla.org/en-US/kb/how-does-phishing-and-malware-protection-work?as=u&utm_source=inproduct 

A fix for that already went into the Firefox UI tests:
https://github.com/mozilla/firefox-ui-tests/commit/c8ecd35d3e556a30176abc7316526339c022ee1b

The reason is that the report URL has been unified to SUMO via bug 1147212. As solution we do no longer have to differentiate between phishing and malware. See bug 1162070 for the fix for firefox ui tests.
(Assignee)

Comment 1

2 years ago
Created attachment 8602160 [details] [diff] [review]
safebrowsing

Similar to the fix for Firefox UI Tests. Just a unification of the report urls.
Assignee: nobody → hskupin
Status: NEW → ASSIGNED
Attachment #8602160 - Flags: review?(cmanchester)
Comment on attachment 8602160 [details] [diff] [review]
safebrowsing

Review of attachment 8602160 [details] [diff] [review]:
-----------------------------------------------------------------

Looks fine.
Attachment #8602160 - Flags: review?(cmanchester) → review+
(Assignee)

Comment 3

2 years ago
https://hg.mozilla.org/qa/mozmill-tests/rev/c5dad685d673 (default)
Status: ASSIGNED → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 40
You need to log in before you can comment on or make changes to this bug.