IonMonkey MIPS: Fix build failure on MIPS (js/src/jit/CodeGenerator.cpp:6740:28: error: ‘obj’ was not declared in this scope)

RESOLVED FIXED in Firefox 41

Status

()

RESOLVED FIXED
4 years ago
4 years ago

People

(Reporter: aleksandar.zlicic, Unassigned)

Tracking

Trunk
mozilla41
Other
Linux
Points:
---

Firefox Tracking Flags

(firefox40 affected, firefox41 fixed)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

4 years ago
Build error:
js/src/jit/CodeGenerator.cpp:6740:28: error: ‘obj’ was not declared in this scope
(Reporter)

Comment 1

4 years ago
Created attachment 8602207 [details] [diff] [review]
Bug_1162134.patch

Patch fixes the build on MIPS.

Build failure was caused by a typo (presumably) in attachment 8590332 [details] [diff] [review].
(Bug 1146597)
Attachment #8602207 - Flags: review?(jdemooij)
Attachment #8602207 - Flags: review?(bhackett1024)
Comment on attachment 8602207 [details] [diff] [review]
Bug_1162134.patch

Review of attachment 8602207 [details] [diff] [review]:
-----------------------------------------------------------------

::: js/src/jit/CodeGenerator.cpp
@@ +6736,5 @@
>      if (unboxedType == JSVAL_TYPE_MAGIC) {
>          Address initLength(elements, ObjectElements::offsetOfInitializedLength());
>          masm.branchKey(Assembler::NotEqual, initLength, ToInt32Key(index), &callStub);
>      } else {
> +        Address initLength(elements, UnboxedArrayObject::offsetOfCapacityIndexAndInitializedLength());

This should be |object|, not |elements|
Attachment #8602207 - Flags: review?(jdemooij)
Attachment #8602207 - Flags: review?(bhackett1024)
Attachment #8602207 - Flags: review+
(Reporter)

Comment 3

4 years ago
Created attachment 8602767 [details] [diff] [review]
Bug_1162134.patch
Attachment #8602207 - Attachment is obsolete: true
Blocks: 1146597
status-firefox40: --- → affected

Updated

4 years ago
Duplicate of this bug: 1161357
Attachment #8602767 - Flags: review?(bhackett1024)
Attachment #8602767 - Flags: review?(bhackett1024) → review+
Keywords: checkin-needed
https://hg.mozilla.org/mozilla-central/rev/681762b5ea5d
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → mozilla41
You need to log in before you can comment on or make changes to this bug.