Ctrl-Shift-L leads to a crash

VERIFIED WORKSFORME

Status

()

Core
Keyboard: Navigation
VERIFIED WORKSFORME
16 years ago
16 years ago

People

(Reporter: Panagiotis Vossos, Assigned: Aaron Leventhal)

Tracking

({crash})

Trunk
x86
Linux
crash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

16 years ago
After firing up mozilla 0.9.6, I do the following:

1) Press Ctrl-Shift-L.
The 'Open Web Location' window comes up, but although it has the focus,
I can't type something in it immediately. So I click with the mouse in 
the white box.

2) Type a URL, press enter, wait half a second and have Mozilla crash.

I have Mozilla-0.9.6 release compiled with the following options:

cat > .mozconfig <<"EOF"
# ...mozilla/.mozconfig
# 
# See www.mozilla.org/build/unix.html for build instructions
ac_add_options --disable-tests
ac_add_options --disable-debug
ac_add_options --disable-logging
ac_add_options --disable-mailnews
ac_add_options --disable-accessibility
ac_add_options --disable-ldap
ac_add_options --disable-xprint
ac_add_options --disable-jsd
ac_add_options --disable-bidi
ac_add_options --enable-strip
ac_add_options --enable-optimize=-O3
ac_add_options --enable-crypto
ac_add_options --with-system-png
ac_add_options --with-system-jpeg
ac_add_options --with-system-zlib
ac_add_options --with-system-mng
# done with .mozconfig
EOF

Compilation with gcc 2.95.3 and glibc 2.1.3.

Thanks for all your hard work.

Comment 1

16 years ago
WorksForMe, Linux 0.9.7 branch 2001122908

I can't reproduce this with todays build, I can type immediately after
Ctrl-Shift-L and don't crash.

Thank's for testing mozilla.

Comment 2

16 years ago
WFM build 2001121008 @ mandrake linux 8.1

Comment 3

16 years ago
0.9.7 will be out the door in a few days.  Please grab that milestone and see if
the problem persists.  Otherwise please resolve this bug as WORKSFORME.
Keywords: crash

Comment 4

16 years ago
WFM. Build ID: 2001 12 20 08. Red Hat Linux 6.2.
ditto, wfm on rh7.2, 2001.12.20.08 comm build.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 16 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 6

16 years ago
I just built 0.9.7 with the same options as 0.9.6, and now Ctrl-Shift-L
works as expected. I can now type immediately after the combo and pressing Enter
no longer crashes. Keep up the good work!
v
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.