Uncaught exception on JavaScript submit

VERIFIED DUPLICATE of bug 115262

Status

()

Core
DOM: Core & HTML
VERIFIED DUPLICATE of bug 115262
17 years ago
10 years ago

People

(Reporter: Alexander Skwar, Assigned: jst)

Tracking

Trunk
x86
All
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

17 years ago
Since 2001-12-17 (or thereabouts) I'm unable to submit some forms which have a
JavaScript document.submit().  Basically it happens with the IMP webmail system.

Clicking on a submit button on one of its forms gives me the following error
message in the JavaScript console:

Error: uncaught exception: [Exception... "Component returned failure code:
0x80004005 (NS_ERROR_FAILURE) [nsIDOMHTMLFormElement.submit]"  nsresult:
"0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame ::
http://alex-bei.dyndns.info/horde/imp/compose.php?popup=1&to=&cc=&bcc=&msg=&subject=&thismailbox=INBOX&uniq=1008847528886
:: uniqSubmit :: line 182"  data: no]

The button executes the following JavaScript source:

document.compose.actionID.value='114'; uniqSubmit();

uniqSumbit() is a JavaScript function defined as follows:

function uniqSubmit()
{
    now = new Date();
    document.compose.action = document.compose.action + now.getTime();
    document.compose.submit();
}

I'll attach the offending HTML source to this bug.

IMP also offers a demo setup on their site at http://demo.horde.org/.  This
sites always runs the latest version of the software and the bug happens there
as well.
(Reporter)

Comment 1

17 years ago
Created attachment 62344 [details]
Page generating the error

Comment 2

17 years ago
Sev: cri -> nor
Severity: critical → normal

Comment 3

17 years ago
I am using build 2001121909, with Windows XP. My build of Mozilla is version 
0.9.7+ it seems E Bay is generating a lot of uncaught exception errors.

Error: uncaught exception: [Exception... "Component returned failure code: 
0x80004002 (NS_NOINTERFACE) [nsIDOMNSHTMLAnchorElement.search]"  
nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: 
http://cgi.ebay.com/aw-cgi/eBayISAPI.dll?ViewItem&item=1311041450 :: 
<TOP_LEVEL> :: line 415"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 
0x80004002 (NS_NOINTERFACE) [nsIDOMNSHTMLAnchorElement.pathname]"  
nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: 
http://cgi.ebay.com/aw-cgi/eBayISAPI.dll?ViewItem&item=1310315033 :: 
<TOP_LEVEL> :: line 462"  data: no]


Error: uncaught exception: [Exception... "Component returned failure code: 
0x80004002 (NS_NOINTERFACE) [nsIDOMNSHTMLAnchorElement.pathname]"  
nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: 
http://cgi.ebay.com/aw-cgi/eBayISAPI.dll?ViewItem&item=1310611909 :: 
<TOP_LEVEL> :: line 472"  data: no]

Error: uncaught exception: [Exception... "Component returned failure code: 
0x80004002 (NS_NOINTERFACE) [nsIDOMNSHTMLAnchorElement.search]"  
nsresult: "0x80004002 (NS_NOINTERFACE)"  location: "JS frame :: 
http://cgi.ebay.com/aw-cgi/eBayISAPI.dll?ViewItem&item=1311931410 :: 
<TOP_LEVEL> :: line 504"  data: no]
(Reporter)

Comment 4

17 years ago
Changing OS to all, as this also happens with 2001122008 on Linux.
OS: Windows NT → All

Comment 5

17 years ago
Duping. Pretty sure if i am wrong please hit me.

*** This bug has been marked as a duplicate of 115262 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → DUPLICATE

Comment 6

17 years ago
marking as dup, the form gets submitted with no errors in the console
Status: RESOLVED → VERIFIED

Updated

10 years ago
Component: DOM: HTML → DOM: Core & HTML
QA Contact: stummala → general
You need to log in before you can comment on or make changes to this bug.