[STK] Browser Termination envelope not received

RESOLVED FIXED in Firefox OS v2.2

Status

Firefox OS
Gaia::System::SIM Tool Kit
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: Anshul, Assigned: seanlee)

Tracking

(Blocks: 1 bug)

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)
Dependency tree / graph

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.2 fixed, b2g-master fixed)

Details

(Whiteboard: [caf priority: p2][CR 833358])

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
STR

STR:

- Run USAT GCF 27.22.7.9.1.1
- Card sends SET UP EVENT LIST: Browser Termination proactive command.
- Start the browser app
- Terminate the browser app by long pressing home button and closing the app

Expected: STK download event when the browser is terminated
Observed: No download event being sent
(Reporter)

Comment 1

3 years ago
The issue seems to be that app.manifest.permissions.browser check at [1] is incorrect and therefore handleBrowserTerminationEvent function never gets called. Browser manifest url at [2] doesn't seem to have any entry for permissions.browser.


[1] http://lxr.mozilla.org/gaia/source/apps/system/js/icc_events.js#262
[2] http://lxr.mozilla.org/gaia/source/apps/search/manifest.webapp#30


Just as an experiment I changed the Gaia code to look at |app.manifest.name === 'Browser'| and then I received the envelope command as expected.

Updated

3 years ago
Whiteboard: [CR 833358]

Updated

3 years ago
Whiteboard: [CR 833358] → [caf priority: p2][CR 833358]
(Assignee)

Updated

3 years ago
Flags: needinfo?(selee)

Comment 2

3 years ago
Triage: blocking
blocking-b2g: 2.2? → 2.2+
Created attachment 8602454 [details] [review]
[gaia] weilonge:seanlee/STK/master/Bug1162224 > mozilla-b2g:master
(Assignee)

Comment 4

3 years ago
Comment on attachment 8602454 [details] [review]
[gaia] weilonge:seanlee/STK/master/Bug1162224 > mozilla-b2g:master

Hi Fernando,

Could you help to review the patch? Thank you.
Flags: needinfo?(selee)
Attachment #8602454 - Flags: review?(frsela)

Comment 5

3 years ago
Hi! Sean,

Since you are working on this case. Over to you. Thanks

--
Keven
Assignee: nobody → selee
Comment on attachment 8602454 [details] [review]
[gaia] weilonge:seanlee/STK/master/Bug1162224 > mozilla-b2g:master

r+ to the patch. Thanks for fixing

The browser app is changing since 2.0 (where permissions.browser exists [1]) and into the last releases it's merged inside system app [2].

I'm worried that using the name for checking it, is a weak solution because it can be changed in the future, but not sure about a better solution now :(

[1] https://github.com/mozilla-b2g/gaia/blob/v2.0m/apps/browser/manifest.webapp#L11
[2] https://bugzilla.mozilla.org/show_bug.cgi?id=1043959
Attachment #8602454 - Flags: review?(frsela) → review+
(Assignee)

Comment 7

3 years ago
landed on master: https://github.com/mozilla-b2g/gaia/commit/d544c9b2a77a889d87566aff0ca957da5089a49e
gaia-try: https://treeherder.mozilla.org/#/jobs?repo=gaia&revision=dbe4ba00e63dfd07d7e68e2ea309dc0662910388
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Assignee)

Comment 8

3 years ago
Comment on attachment 8602454 [details] [review]
[gaia] weilonge:seanlee/STK/master/Bug1162224 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #):
[User impact] if declined:
Browser Termination envelope is not received correctly.

[Testing completed]:
Write unit-test for this and it passes.

[Risk to taking this patch] (and alternatives if risky):
Only change how to check Browser app terminated. Very minor.

[String changes made]:
None.
Attachment #8602454 - Flags: approval-gaia-v2.2?

Updated

3 years ago
Attachment #8602454 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
v2.2: https://github.com/mozilla-b2g/gaia/commit/8d2901e900683195a6a9caf79a3338307e98997d
status-b2g-v2.2: --- → fixed
status-b2g-master: --- → fixed
Target Milestone: --- → 2.2 S12 (15may)
You need to log in before you can comment on or make changes to this bug.