mediastream attached to two video elements stops when one element is removed

RESOLVED WORKSFORME

Status

()

Core
WebRTC
P2
normal
Rank:
25
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: fippo, Unassigned)

Tracking

37 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Ubuntu Chromium/41.0.2272.76 Chrome/41.0.2272.76 Safari/537.36

Steps to reproduce:

go to http://hancke.name/tmp/remove-bug.html
allow camera access. Two videos appear.

Remove one of the elements by calling 
document.getElementById('vid1').remove()
in the JS console


Actual results:

the second video is stopped as well.


Expected results:

the second video is not affected.

Workaround: call
document.getElementById('vid1').mozSrcObject = null
before removing the video.
backlog: --- → webRTC+
Rank: 25
Priority: -- → P2
Status: UNCONFIRMED → NEW
Ever confirmed: true
This was supposedly fixed by bug 1073406. Also, I can't reproduce your test case on Firefox 40.
(In reply to Andreas Pehrson [:pehrsons] (Telenor) from comment #1)
> This was supposedly fixed by bug 1073406. Also, I can't reproduce your test
> case on Firefox 40.

Likewise in 41. Are you perhaps on 37?
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Flags: needinfo?(fippo)
Resolution: --- → WORKSFORME
(In reply to Andreas Pehrson [:pehrsons] (Telenor) from comment #2) 
> Are you perhaps on 37?

Oh, yes I see you specified "37 branch" as the version now. Nice that we had this fixed in release some 10 days after you filed this bug then. ;-)
Flags: needinfo?(fippo)
You need to log in before you can comment on or make changes to this bug.