Favicon of first and/or last bookmark in folder does not initially appear in Bookmarks Library

RESOLVED WORKSFORME

Status

()

Firefox
Bookmarks & History
RESOLVED WORKSFORME
3 years ago
a year ago

People

(Reporter: quality+bugzilla, Unassigned)

Tracking

37 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

1. Open Bookmarks Library
2. Left-click on any folder in the tree


Actual results:

Bookmarks in the folder appear, but the favicon of the first and/or last bookmark in the folder do not appear.  The space for the favicon is completely empty (not the dashed box that is used for sites without favicons).  Sometimes it is the first bookmark, sometimes the last, sometimes both.  Almost never happens to bookmarks except the first or last in a folder.  On rare occasions, it happens to the second bookmark in a folder.

This happens about 5-10% of the time, and appears random.

Simply selecting another folder, and then re-selecting the folder with the missing favicons will make them reappear.  Also, hovering the cursor over a bookmark missing it's favicon will cause the favicon to appear.

Note 1: As indicated by the workaround above, the bookmarks certainly have favicons assigned.
Note 2: The folders and timing of when this happens seems to be random.  It will happen on different folders at different times.  IOW, it does not seem to be specific to certain folders or bookmarks.


Expected results:

Favicons of all bookmarks (that have favicons) should always be displayed within the Bookmarks Library.

Other details: Tested and verified with default theme and common Intel HD 4000 Graphics chipset.
Hello,

Are you still encountering this bug on the newest Firefox build 42.0 or Nightly 46.0a1?

I can not reproduce in Firefox 42.0 or Nightly 46.0a1 on Win 7 or Win 8.1.

Name 	Firefox
Version 	46.0a1
Build ID 	20151217030207
User Agent 	Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:46.0) Gecko/20100101 Firefox/46.0

Thank you,

Justin
Component: Untriaged → Bookmarks & History
Flags: needinfo?(quality+bugzilla)
(Reporter)

Comment 2

2 years ago
Hi Justin,

Thank you for your followup.  I sincerely appreciate it.

I just tried it on Firefox 43.0, and I did not encounter the issue this one time.

Overall, the Bookmarks Library seems a little more responsive, but that's just based on my memory, not any empirical data.

Since the issue was random in nature, this does not mean it is fixed, but does not mean it is still broken, either.  I'll keep trying it once in a while, and will report my findings to this bug report.

Firefox 43 broke many search-related extensions, and I'm active trying to see what I can do to help.

I will leave the needinfo flag enabled for this bug at this time.  If you think it's more appropriate to turn off that flag, that's good too.
Flags: needinfo?(quality+bugzilla)
(Reporter)

Comment 3

2 years ago
Oops.  I accidentally cleared the needinfo flag.  If you think it should be on, please feel free to re-engage it.
Alright I will turn the need info flag back on and also resolve this bug. I will also keep my name CC'd and if this bug does occur again, we will reopen it!

Thanks for the speedy reply,

Justin
Status: UNCONFIRMED → RESOLVED
Last Resolved: 2 years ago
Flags: needinfo?(quality+bugzilla)
Resolution: --- → WORKSFORME
Flags: needinfo?(quality+bugzilla)
(Reporter)

Comment 5

a year ago
Did not see this issue when testing on Firefox 43.0.0 to 47.0.1.
You need to log in before you can comment on or make changes to this bug.