Closed Bug 1162362 Opened 5 years ago Closed 5 years ago

Regression of Robocop due to bug 1155338

Categories

(Testing :: Mochitest, defect)

ARM
Android
defect
Not set

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 1162479

People

(Reporter: capella, Unassigned)

References

Details

Pulled m-c today and rebuilt, subsequent local Robocop testing is failing. Bisected to bug 1155338 ... backout gets me testing again.

Condensed logcat is:


 0:00.92 LOG: MainThread INFO Device info:
 0:01.56 LOG: MainThread INFO   uptime: 96 days 17 hours 7 minutes 43 seconds
 0:01.56 LOG: MainThread INFO   memtotal: 1849124 kB
 0:01.56 LOG: MainThread INFO   process:
 0:01.56 LOG: MainThread INFO      USER     PID   PPID  VSIZE  RSS     WCHAN    PC         NAME
 0:01.56 LOG: MainThread INFO      root      1     0     684    544   ffffffff 00000000 S /init
 0:01.56 LOG: MainThread INFO      root      2     0     0      0     ffffffff 00000000 S kthreadd
 0:01.56 LOG: MainThread INFO      root      3     2     0      0     ffffffff 00000000 S ksoftirqd/0
...
...
...
... 
 0:01.58 LOG: MainThread INFO      root      24709 430   5216   512   ffffffff 00000000 S daemonsu:10119
 0:01.58 LOG: MainThread INFO      root      25083 2     0      0     ffffffff 00000000 S flush-179:0
 0:01.58 LOG: MainThread INFO      root      27134 430   8936   3176  ffffffff 00000000 S daemonsu:0
 0:01.58 LOG: MainThread INFO      u0_a51    29024 9622  907068 42788 ffffffff 00000000 S com.android.vending
 0:01.58 LOG: MainThread INFO      root      29416 430   10824  3016  ffffffff 00000000 S daemonsu:10070
 0:01.58 LOG: MainThread INFO      u0_a43    32751 9622  906216 43692 ffffffff 00000000 S com.google.android.music:main
 0:01.58 LOG: MainThread INFO   systime: Wed May  6 23:36:09 EDT 2015
 0:01.58 LOG: MainThread INFO   disk:
 0:01.58 LOG: MainThread INFO      Filesystem               Size     Used     Free   Blksize
 0:01.58 LOG: MainThread INFO      /data                   12.2G     6.0G     6.2G   4096
 0:01.58 LOG: MainThread INFO      /system                827.8M   727.0M   100.8M   4096
 0:01.58 LOG: MainThread INFO      /sdcard                 12.2G     6.0G     6.2G   4096
 0:01.58 LOG: MainThread INFO   os: KTU84L
 0:01.58 LOG: MainThread INFO   id: 08562eeb
 0:01.65 LOG: MainThread INFO Test root: /storage/sdcard0/tests
 0:01.72 LOG: MainThread INFO Android sdk version '19'; will use this to filter manifests
 0:03.89 SUITE_START: MainThread 1
 0:04.11 LOG: MainThread INFO Checking for orphan ssltunnel processes...
 0:04.18 LOG: MainThread INFO Checking for orphan xpcshell processes...
 0:04.21 LOG: ProcessReader INFO master    9738  9735  0 23:36 pts/7    00:00:00 /bin/sh -c if [ '/home/master/mozilla-central-objff/dist/bin' = '' ]; then \         echo 'environment variable MOZ_HOST_BIN must be set to a directory containing host xpcshell'; \     elif [ ! -d /home/master/mozilla-central-objff/dist/bin ]; then \         echo 'MOZ_HOST_BIN does not specify a directory'; \     elif [ ! -f /home/master/mozilla-central-objff/dist/bin/xpcshell ]; then \         echo 'xpcshell not found in MOZ_HOST_BIN'; \     elif [ '' = '' -a 'adb' != 'adb' ]; then \         echo 'please prepare your host with the environment variable TEST_DEVICE'; \     else \         rm -f ./mochitest-robocop.log && /home/master/mozilla-central-droid/_virtualenv/bin/python _tests/testing/mochitest/runtestsremote.py --robocop-apk=./build/mobile/robocop/robocop-debug.apk --robocop-ids=./mobile/android/base/fennec_ids.txt --robocop-ini=_tests/testing/mochitest/robocop.ini --log-tbpl=./mochitest-robocop.log  --dm_trans=adb --app=org.mozilla.fennec --deviceIP= --xre-path=/home/master/mozilla-central-objff/dist/bin --symbols-path=dist/crashreporter-symbols --test-path='testSelectionHandler' ; \     fi

 0:09.31 LOG: MainThread ERROR Automation Error: Exception caught while running tests
Traceback (most recent call last):
  File "_tests/testing/mochitest/runtestsremote.py", line 639, in run_test_harness
    result = mochitest.runTests(options)
  File "/home/master/mozilla-central-droid/_tests/testing/mochitest/runtests.py", line 2111, in runTests
    return self.runMochitests(options, testsToRun, onLaunch)
  File "/home/master/mozilla-central-droid/_tests/testing/mochitest/runtests.py", line 2048, in runMochitests
    result = self.doTests(options, onLaunch, testsToRun)
  File "/home/master/mozilla-central-droid/_tests/testing/mochitest/runtests.py", line 2183, in doTests
    self.manifest = self.buildProfile(options)
  File "_tests/testing/mochitest/runtestsremote.py", line 177, in buildProfile
    manifest = Mochitest.buildProfile(self, options)
  File "/home/master/mozilla-central-droid/_tests/testing/mochitest/runtests.py", line 1436, in buildProfile
    self.copyExtraFilesToProfile(options)
  File "/home/master/mozilla-central-droid/_tests/testing/mochitest/runtests.py", line 879, in copyExtraFilesToProfile
    shutil.copytree(abspath, dest)
  File "/usr/lib/python2.7/shutil.py", line 177, in copytree
    os.makedirs(dst)
  File "/home/master/mozilla-central-droid/_virtualenv/lib/python2.7/os.py", line 157, in makedirs
    mkdir(name, mode)
OSError: [Errno 17] File exists: '/tmp/tmpzqg6JT.mozrunner/plugins'
 0:09.38 LOG: MainThread WARNING Unable to retrieve log file (/storage/sdcard0/tests/logs/mochitest.log) from remote device
INFO | runtests.py | Test summary: start.
0 INFO SimpleTest START
1 INFO TEST-START | Shutdown
2 INFO Passed: 0
3 INFO Failed: 0
4 INFO Todo: 0
5 INFO SimpleTest FINISHED
INFO | runtests.py | Test summary: end.
 0:09.78 SUITE_END: MainThread 
Summary
=======

Ran 0 tests
Expected results: 0
Unexpected results: 0

OK
make: *** [mochitest-robocop] Error 1
See Also: → 1162479
What is the command line you're using to run this? Are you using mach?
This looks like the same error as bug 1162479, if you are using the make targets, please try running: |mach robocop| instead.
I'm duping this to the other bug because the other one has a more general description.
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1162479
Yep, old-school using the make syntax ... switched and all is well ... 

"someone moved my cheese"  :-)
You need to log in before you can comment on or make changes to this bug.