Last Comment Bug 1162380 - Drop down list in Customize Toolbar is too small
: Drop down list in Customize Toolbar is too small
Status: RESOLVED FIXED
:
Product: Calendar
Classification: Client Software
Component: Lightning Only (show other bugs)
: Lightning 3.3
: Unspecified Unspecified
-- normal (vote)
: 4.3
Assigned To: Decathlon
:
:
Mentors:
Depends on: 1208704
Blocks:
  Show dependency treegraph
 
Reported: 2015-05-06 22:44 PDT by Zamir SUN
Modified: 2015-12-10 09:40 PST (History)
4 users (show)
See Also:
Crash Signature:
(edit)
QA Whiteboard:
Iteration: ---
Points: ---


Attachments
patch - v1 (205 bytes, patch)
2015-05-21 10:49 PDT, Decathlon
philipp: review-
Details | Diff | Splinter Review
patch - v1 (2.27 KB, patch)
2015-05-21 12:42 PDT, Decathlon
philipp: review+
Details | Diff | Splinter Review

Description User image Zamir SUN 2015-05-06 22:44:53 PDT
User Agent: Mozilla/5.0 (X11; Fedora; Linux x86_64; rv:36.0) Gecko/20100101 Firefox/36.0
Build ID: 20150220131016

Steps to reproduce:

1. Install Thunderbird 31.6 and lightning 3.3.3
2. Go to Calendar view
3. Right click on menu bar, choose Customize
4. See the drop down list in "Show"



Actual results:

The drop down list is blank by default and is not the same height with "Show"


Expected results:

The drop down list should be the same height with "Show" as when we trigger it on main view.
Comment 1 User image sun.ziqian 2015-05-07 00:34:45 PDT
This also exists on Solaris.
Comment 2 User image [:MakeMyDay] 2015-05-09 03:10:58 PDT
The same appears in Daily. If you selcet an item from the dropdown list and closes the dialog and than reopen the customize dialog, the previous selection is only persisted as you haven't switched to another tab. The same applies on task view.

I'm wondering if there's any attribute/property we're missing in the toolbar definitions in lightning-toolbar.xul which triggers that behaviour or is this a toolkit issue.
Comment 3 User image [:MakeMyDay] 2015-05-20 00:17:10 PDT
Philipp, do you know what attribute triggers pre-setting of the dropdown selection?
Comment 4 User image Philipp Kewisch [:Fallen] 2015-05-20 02:22:40 PDT
Ah I see. So we have this modebox binding that sets the "mode" attribute to whatever mode is active (calendar,mail,tasks). The toolbox uses the mode attribute to determine what mode it is in, for example the mail toolbar has the attribute set to "full" for me.

I don't know why the mode attribute is being modified on that node, I thought it only happens on modeboxes.
Comment 5 User image Decathlon 2015-05-21 10:49:05 PDT
Created attachment 8608857 [details] [diff] [review]
patch - v1

In the toolbox the attribute "mode", related to the Lightning's current mode (mail, calendar, task), overwrites the attribute "mode" used to set the value in the drop down menu (full, icons, text, textbesideicon). This was my error from another patch.

In this patch I've used modeboxes without set the attribute "refcontrol" because the attribute "collapsed" in the toolbars already allows to hide the toolbar for each mode. Could it be a problem for the modeboxes a missing refcontrol?
I've also changed the order of two items in the context menu for the menu bar so we have the same context menu of the toolbar.

I wanted to test on SeaMonkey, but I'm not able to find a recent version for Windows (zip version, without installer) with a working Lightning. What version should I use, and where I can download it?
Comment 6 User image Philipp Kewisch [:Fallen] 2015-05-21 12:23:15 PDT
Comment on attachment 8608857 [details] [diff] [review]
patch - v1

Looks like the patch is empty? I just see the header.

I believe Seamonkey is suffering issues with their nightly builds at the moment, their tree has been closed for a while.
Comment 7 User image Decathlon 2015-05-21 12:42:45 PDT
Created attachment 8608935 [details] [diff] [review]
patch - v1

Sometimes it helps doing a qrefresh (and verify the file before posting) ;-)
Comment 8 User image Philipp Kewisch [:Fallen] 2015-05-29 00:36:49 PDT
Comment on attachment 8608935 [details] [diff] [review]
patch - v1

Review of attachment 8608935 [details] [diff] [review]:
-----------------------------------------------------------------

As long as it works in Thunderbird it should be fine, we can wait for a bug report in Seamonkey. r=philipp
Comment 9 User image Stefan Sitter 2015-05-31 06:58:27 PDT
Pushed to https://hg.mozilla.org/comm-central/rev/3fe65676c36b

Note You need to log in before you can comment on or make changes to this bug.