[NFC] Cannot share image which is opened from notification

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: ashiue, Assigned: gduan)

Tracking

({regression})

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.193508
Firmware Date          Wed May  6 19:35:21 EDT 2015
Bootloader             L1TC100118D0

STR:
1. Receive a image from other device
2. Open the image from notification
3. While viewing image from notification, set back to other device to initiate an NFC transfer
4. Try to swipe shrinking UI to share file

Expected result:
Can swipe shrinking UI to share file

Actual result:
Cannot swipe shrinking UI  (http://youtu.be/HxqKOxSQZp8)
(Reporter)

Comment 1

4 years ago
[Blocking Requested - why for this release]:
Regression issue
blocking-b2g: --- → 3.0?
QA Whiteboard: [COM=NFC]
triage: regression, function broken
blocking-b2g: 3.0? → 3.0+
Keywords: regression
blocking-b2g: 3.0+ → spark+
Flags: needinfo?(dflanagan)
Weird. There have been very few gaia changes here between 2.2 and 3.0. Unless the jshint compliance patch messed something up, I suspect this is a gecko issue.

Punam: I'm tied up with other gallery image memory bugs. You know the NFC code and spark. Could you help investigate this and determine whether it is something broken in Gallery?
Flags: needinfo?(dflanagan)
Flags: needinfo?(pdahiya)
Ni gecko developer and see their opinions on comment 3.
Flags: needinfo?(allstars.chh)
notification should be related to system app changes, 
and we didn't do any major change after v2.2
Flags: needinfo?(allstars.chh)
ni Alive to comment from system app.
Flags: needinfo?(alive)
Delivering NI to George, please help to check what's happening here, thanks.
Flags: needinfo?(alive) → needinfo?(gduan)
See Also: → 1163957
QA Contact: pcheng
b2g inbound regression window:

Last Working
Device: Flame
BuildID: 20150504041100
Gaia: 1336ecf1b157824c61c93b81b1759399a80fae2b
Gecko: ea65aaa6b1ae
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken
Device: Flame
BuildID: 20150504044407
Gaia: c48bc387de07f9eb005fa37a4c315e39bab9b6c6
Gecko: c8f17c8ae839
Gonk: 040bb1e9ac8a5b6dd756fdd696aa37a8868b5c67
Version: 40.0a1 (3.0 Master) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working Gaia & First Broken Gecko - issue does NOT repro
Gaia: 1336ecf1b157824c61c93b81b1759399a80fae2b
Gecko: c8f17c8ae839

Last Working Gecko & First Broken Gaia - issue DOES repro
Gaia: c48bc387de07f9eb005fa37a4c315e39bab9b6c6
Gecko: ea65aaa6b1ae

Gaia pushlog:
https://github.com/mozilla-b2g/gaia/compare/1336ecf1b157824c61c93b81b1759399a80fae2b...c48bc387de07f9eb005fa37a4c315e39bab9b6c6

Caused by bug 1158379.
Blocks: 1158379
QA Whiteboard: [COM=NFC] → [QAnalyst-Triage?][COM=NFC]
Flags: needinfo?(ktucker)
George, can you take a look at this please? This might have been caused by the landing for bug 1158379.
QA Whiteboard: [QAnalyst-Triage?][COM=NFC] → [QAnalyst-Triage+][COM=NFC]
Flags: needinfo?(ktucker)
Comment on attachment 8605004 [details] [review]
[gaia] cctuan:1162384 > mozilla-b2g:master

Hi Alive, 
Could you help me to review this patch?
I found that I should return frontWindow's _showScreenshotOverlay if app has frontWindow, otherwise, the callback will never be triggered.

Thanks.
Flags: needinfo?(gduan)
Attachment #8605004 - Flags: review?(alive)
Assignee: nobody → gduan
Comment on attachment 8605004 [details] [review]
[gaia] cctuan:1162384 > mozilla-b2g:master

r+ with nit
Attachment #8605004 - Flags: review?(alive) → review+
Whiteboard: checkin-needed
merge to master: https://github.com/mozilla-b2g/gaia/commit/3fc22ca62b56276f264cc0e7c1276bd5e877e2be
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
Flags: needinfo?(pdahiya)
Whiteboard: checkin-needed
Target Milestone: --- → 2.2 S12 (15may)
(Reporter)

Comment 14

4 years ago
Verified on

Build ID               20150518160201
Gaia Revision          762cbd16712484f93f485e89f5363686540a3db7
Gaia Date              2015-05-18 18:07:25
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/e94dc650c901
Gecko Version          41.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150518.194829
Firmware Date          Mon May 18 19:48:46 EDT 2015
Bootloader             HHZ12f
Status: RESOLVED → VERIFIED
Since we are about to land bug 1158379 to 2.2, this one will be 2.2:affected so we'll need to uplift it as well.
blocking-b2g: spark+ → 2.2+
Comment on attachment 8605004 [details] [review]
[gaia] cctuan:1162384 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): This commit is to fix regression of bug 1158379.
[User impact] if declined: User might see pb as comment 0.
[Testing completed]: Yes, cover manual and unit test.
[Risk to taking this patch] (and alternatives if risky): This bug should be merged to 2.2 later than bug 1158379.
[String changes made]:
Attachment #8605004 - Flags: approval-gaia-v2.2?
Comment on attachment 8605004 [details] [review]
[gaia] cctuan:1162384 > mozilla-b2g:master

Approving and requesting QA verifyme after patch land on 2.2
Attachment #8605004 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 19

4 years ago
Verified on v2.2:
Build ID               20150526162504
Gaia Revision          15fa6e486b5c82956a8e8f8a99c39d297e8f0523
Gaia Date              2015-05-26 20:07:31
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/663bf4703588
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150526.201446
Firmware Date          Tue May 26 20:14:55 EDT 2015
Bootloader             L1TC100118D0
You need to log in before you can comment on or make changes to this bug.