[Camera]The string "Retake" on the button is truncated.

VERIFIED FIXED in 2.2 S12 (15may)

Status

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: huayu.li, Assigned: sfoster)

Tracking

unspecified
2.2 S12 (15may)
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.2+, b2g-v2.1 unaffected, b2g-v2.2 verified, b2g-master verified)

Details

(Whiteboard: LocRun2.2, [systemsfe])

Attachments

(5 attachments)

(Reporter)

Description

4 years ago
[1.Description]:
[Flame2.2][Camera]When we take a picture as attachment,  the string "Retake" on the button is truncated.
See attachment:
Portuguese from Brazil_retake.png
Portuguese from Portugal_retake.png

[2.Testing Steps]: 
Prerequisite:Switch system language to Portuguese from Brazil/Portuguese from Portugal
1.Launch message.
2.Launch new message button.
3.Tap add attachment button.
4.Select camera.
5.Take a picture.

[3.Expected Result]: 
5.The string "Retake" on the button is NOT truncated.

[4.Actual Result]: 
5.The string "Retake" on the button is truncated.

[5.Reproduction build]: 

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8.Note]:
This issue does NOT exist in Spanish, Polish, Serbian Cyrillic, Russian, Greek, Arabic,Bengali from India, Basque.
(Reporter)

Comment 2

4 years ago
[5.Reproduction build]: 
Device: Flame 2.1 user (Unaffected)
Build ID               20150506001242
Gaia Revision          b4a03b7ee61de5a479b3cf0916f47e91a43b0f50
Gaia Date              2015-04-30 21:31:55
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g34_v2_1/rev/4493015380ab
Gecko Version          34.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.035318
Firmware Date          Wed May  6 03:53:29 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 2.2 user (Affected)
Build ID               20150506002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3af6a0a79227
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.040211
Firmware Date          Wed May  6 04:02:22 EDT 2015
Bootloader             L1TC000118D0
[6.Reproduction Frequency]: 
Always Recurrence,5/5
Regression - blocking
blocking-b2g: --- → 2.2+
(Assignee)

Comment 5

4 years ago
Comment on attachment 8602987 [details] [review]
[gaia] sfoster:camera-confirm-btn-bug-1162440 > mozilla-b2g:master

More bug 1010675 fallout, see PR for details.
Attachment #8602987 - Flags: review?(dflanagan)
(Assignee)

Updated

4 years ago
Assignee: nobody → sfoster
Whiteboard: LocRun2.2,MGSEI-l10n-1F → LocRun2.2,MGSEI-l10n-1F [systemsfe]
Target Milestone: --- → 2.2 S12 (15may)
Comment on attachment 8602987 [details] [review]
[gaia] sfoster:camera-confirm-btn-bug-1162440 > mozilla-b2g:master

r+, but I'd suggest that you add a comment indicating that the padding is explicitly overriding shared/style/buttons.css because we have past string freeze.

Are you going to land this on master, or just on 2.2?

In either case, consider filing a followup bug to get the pt_BR string shortened, and to remove this padding hack in the 3.0 release.
Attachment #8602987 - Flags: review?(dflanagan) → review+
(Assignee)

Updated

4 years ago
See Also: → 1162792
(Assignee)

Updated

4 years ago
See Also: → 1162794
(Assignee)

Comment 7

4 years ago
Filed follow up bug 1162792 to get the pt-BR string shortened, and bug 1162794 to undo this patch when possible. 
I updated the PR with a comment on the override. We've been landing these on master then uplifting. I don't want to assume we'll have all this fixed by the next release so if we dont get the patches on master we risk having to do it all again. Longer term we need to resolve the issue of all these similar-but-different buttons. I think there's a tentative plan to migrate all instances to the button web-component?
Keywords: checkin-needed
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → FIXED
(Assignee)

Comment 9

4 years ago
Comment on attachment 8602987 [details] [review]
[gaia] sfoster:camera-confirm-btn-bug-1162440 > mozilla-b2g:master

[Approval Request Comment]
[Bug caused by] (feature/regressing bug #): Camera activity confirm buttons (post-fix for bug 1010675)
[User impact] if declined: Button labels may be truncated and meaning unclear in some languages
[Testing completed]: Tested on device in multiple languages
[Risk to taking this patch] (and alternatives if risky): Low risk, tightly constrained CSS only patch 
[String changes made]: None
Attachment #8602987 - Flags: approval-gaia-v2.2?
Attachment #8602987 - Flags: approval-gaia-v2.2? → approval-gaia-v2.2+
(Reporter)

Comment 13

4 years ago
This issue has been verified as pass on flame2.2&3.0
Reproduce rate:0/5

Device: Flame 2.2 user
Build ID               20150510002505
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.043421
Firmware Date          Sun May 10 04:34:32 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 user
Build ID               20150510010201
Gaia Revision          5b2a150f6f5d29bddfaac13fcbbf099376f2f275
Gaia Date              2015-05-09 12:34:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/77d92f6d7679
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.044245
Firmware Date          Sun May 10 04:42:56 EDT 2015
Bootloader             L1TC000118D0
Status: RESOLVED → VERIFIED
QA Whiteboard: [MGSEI-Triage+][MGSEI-l10n-1F]
Whiteboard: LocRun2.2,MGSEI-l10n-1F [systemsfe] → LocRun2.2, [systemsfe]
You need to log in before you can comment on or make changes to this bug.