If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[First Time Experience]Facebook is checking all the time when we've accessed FTE page to import contacts and return to choose language.

RESOLVED INVALID

Status

Firefox OS
Gaia::First Time Experience
P2
normal
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: zouyi(Leave from Mozilla), Unassigned, Mentored)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(blocking-b2g:2.5+, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8602621 [details]
logcat002.txt

[1.Description]:
[Nexus 5][v2.2&v3.0][Flamev2.2&v3.0]When we've accessed FTE page to import contacts and return to choose language, then tap the next button to Import Ccontact page,we can see that Facebook is checking all the time.
Time:3:18
See attachment:.VID_0005,logcat002.txt
[2.Testing Steps]: 
1.Open FTU via flash device or developer menu.
2.Tap the Next button and connect a wifi,then tap the Next button to enter import contacts page.
3.Choose Facebook,and log in.
4.Click the 'x' button,and tap the back button to return to language page.
5.Choose other language and tap the next button to enter Import Contacts page.

[3.Expected Result]: 
5.We can click the Facebook to import contacts.

[4.Actual Result]: 
5.The Facebook is checking all the time and is not available.

[5.Reproduction build]: 
Device: Flame 2.2 (affected)
Build ID               20150506002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3af6a0a79227
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.040209
Firmware Date          Wed May  6 04:02:20 EDT 2015
Bootloader             L1TC000118D0

Device: Flame 3.0 (affected)
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.193508
Firmware Date          Wed May  6 19:35:21 EDT 2015
Bootloader             L1TC000118D0

Device: Nexus 5 2.2 (affected)
Build ID               20150506002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3af6a0a79227
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150506.040123
Firmware Date          Wed May  6 04:01:41 EDT 2015
Bootloader             HHZ12f

Device: Nexus 5 3.0 (affected)
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150506.192419
Firmware Date          Wed May  6 19:24:33 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8602623 [details]
VID_0005.mp4
(Reporter)

Comment 2

3 years ago
[3.Expected Result]: 
5.We can click the Facebook to import contacts.
change to:
[3.Expected Result]: 
5.The count of facebook contact that you imported should be displayed in the language you choose.
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
I cannot reproduce that by entering FTU right after flashing. Hi ZouYi, Could you also check that, thank you.

1.Open FTU via flash device or developer menu.
Flags: needinfo?(yi.zou)
Hi Gregor, Are you helping with FTU, we have a case that changing language will result in changing one of the message string, you can see that in the attached video. Suggest to backlog or fix this as this is an edge case, thanks.
Flags: needinfo?(yi.zou) → needinfo?(anygregor)
[Blocking Requested - why for this release]: Misleading message after language change in the FTU 

(In reply to Eric Chang [:ericcc] [:echang] from comment #4)
> Hi Gregor, Are you helping with FTU, we have a case that changing language
> will result in changing one of the message string, you can see that in the
> attached video. Suggest to backlog or fix this as this is an edge case,
> thanks.

Ok I can reproduce this - it appears that after changing the language the summary of Facebook friends imported gets replaced with the fb-checking message. I don't think we would block v2.2 on this edge case, but I've nominated it for 3.0. Its seem like a plausible - if uncommon - case to me, and clearly a bug we want to get fixed.
Mentor: sfoster@mozilla.com
blocking-b2g: --- → 3.0?
Flags: needinfo?(anygregor)
Priority: -- → P2
blocking-b2g: 3.0? → 3.0+
We removed the facebook import from the FTU in bug 1175491. If that feature returns it will be a new implementation, so resolving invalid.
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.