[Flame][Settings] Sometimes device will back to Home when we slide the screen edge of system language selector view to enter another app and switch back.

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Settings
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: Boon, Unassigned)

Tracking

({regression})

unspecified
ARM
Gonk (Firefox OS)
regression

Firefox Tracking Flags

(b2g-v2.2 unaffected, b2g-master affected)

Details

Attachments

(2 attachments)

5.54 MB, video/mp4
Details
802.28 KB, text/plain
Details
(Reporter)

Description

3 years ago
Created attachment 8602640 [details]
2050.MP4

[1.Description]:
[Flame v3.0][Settings]Sometimes device will back to Home when we slide the screen edge of system language selector view to enter another app and switch back.
Time: 20:50
See attachment:2050.mp4, logcat-2050.txt

[2.Testing Steps]: 
Precondition: More than one program running in the background
1. Enter the settings App, select the language.
2. Open system language selector view.
3. Slide the screen edge to enter another App.
4. Then return to the language setting view.  


[3.Expected Result]: 
4.You can return to the language setting view and can select your wanted labguage.  

[4.Actual Result]: 
4.You will return to the main view of settings, but sometimes you will back to Home.

[5.Reproduction build]: 
Flame 2.2 (Unaffected):
Build ID               20150506002501
Gaia Revision          772a9491909abd02dc67278dd453746e2dd358a8
Gaia Date              2015-05-05 02:02:24
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/3af6a0a79227
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.040209
Firmware Date          Wed May  6 04:02:20 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0(Affected):
Build ID               20150506160205
Gaia Revision          426fe6450ab8da92bb473fef12ccb39c6c920dd0
Gaia Date              2015-05-06 08:40:16
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5593ac626826
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150506.193508
Firmware Date          Wed May  6 19:35:21 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Occasionally Recurrence,2/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8602642 [details]
logcat-2050.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → unaffected
status-b2g-master: --- → affected
(Reporter)

Updated

3 years ago
See Also: → bug 1162451
Flags: needinfo?(gchang)
NI window management owner for this.
Hi Hermes,
Can you help on this one?
Flags: needinfo?(gchang) → needinfo?(hcheng)
Flags: needinfo?(hcheng)
Keywords: regression, regressionwindow-wanted
This is a performance issue and has been filed many times before. See bug 1152704, bug 1161233, bug 1161189, and bug 1162535. We can't find windows on performance issues because the window will be inaccurate since the cause of regression is not from one single patch.
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: regressionwindow-wanted
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)

Comment 4

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.