Closed Bug 116247 Opened 20 years ago Closed 3 years ago

doesn't show options in list box for Filter and Search Mail

Categories

(MailNews Core :: Filters, defect)

x86
Windows 2000
defect
Not set
major

Tracking

(Not tracked)

VERIFIED WORKSFORME

People

(Reporter: ildella, Assigned: naving)

Details

On Filter menu, as in the Search Menu for mail (search in newsgroup works
correctly) the options like 'to' 'sender' 'body' etc. doesn't appear.
I have the problem in every build I tried post 095 (095 excluded). 
Now I have a clean install of mozilla (reinstall W2K) and the problem persist on
recent build (I'm using 2001121906), while other bugs I found in recent builds
disappear after the w2k reinstall.

I see right now that I can't go in the text area of compose window... and that
mozilla show me HTML compose window, in opposition to my preference... is a new
problem... but this is another bug.
There is also a thread about this bug on mail-news newsgroup:
news://netscape.public.mozilla.mail-news:17682
if the link is wrong, the topic is 
"moz 0.9.6 message filters not working"
I can reproduce this bug on W98 SE since 0.9.6 and it's still in 0.9.7. I'm able
to get the search options back, when I switch the "Search for item in" to a
newgroup. But then the "search"-button itself does nothing until i click "More"
once. Then going back to the Inbox-folder the options are still there and I can
search my emails. When I close and open the search-window again the options are
still gone, though. So the "workaround" is rather annoying - this should
definitely be fixed before 1.0 as I believe searching emails is a oft-used feature.
This may be a duplicate of bug 112927
Do you see this problem in latest builds?
Still the same behavior in 0.9.8 for me :-(
Please try with 0.9.9 build.  There was a (partial) fix for bug 112927 which may
be the root cause.  Marking this worksforme/duplicate, if you still have
problems in 9.9 reopen.
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → WORKSFORME
marking verified worksforme
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
Pushed by mozilla@jorgk.com:
https://hg.mozilla.org/comm-central/rev/c61d7d8e0fc5
Removed remaning #ifdef PR_LOGGING from mailnews and ldap. r=aceman
Status: VERIFIED → RESOLVED
Closed: 19 years ago3 years ago
Resolution: WORKSFORME → FIXED
That commit message had the wrong bug number :-(
Status: RESOLVED → VERIFIED
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.