Closed Bug 1162490 Opened 5 years ago Closed 5 years ago

[regression] Normal Windows have no drop-shadow using developer-theme

Categories

(Core :: Widget: Cocoa, defect)

40 Branch
Unspecified
macOS
defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: metasieben, Assigned: bgrins)

References

Details

(Keywords: regression)

Attachments

(1 file)

Since yesterdays Nightly(2015-05-06) the main window doesn't show the typical drop-shadow anymore when using the developer-theme, however private windows do.
On which (version of which) OS (the bugreport field says OS X; is this accurate and if so, yosemite or 10.9 or something else?)? Can you provide a screenshot?
Flags: needinfo?(mozilla)
Keywords: regression
I can reproduce this with latest nightly on OS X 10.9, at least...
Status: UNCONFIRMED → NEW
Ever confirmed: true
Flags: needinfo?(mozilla)
Markus, this seems like a Cocoa thing... any idea what's up?
Component: Theme → Widget: Cocoa
Flags: needinfo?(mstange)
Product: Firefox → Core
tn, any chance this was bug 1159772?

m-c regression window seems to be: https://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=4c93d46ab92f&tochange=60349cbc3d4e per comment #0, looking at inbound right now to narrow it down further.
Flags: needinfo?(tnikkel)
Interestingly, on bad builds I see the top of the window (near the tabbar etc.) losing shadow first, as soon as I change the theme, but the bottom keeps it until I switch apps and back again...
Brian, looks like changing the accentcolor regressed this. Reverting that change fixes this issue...
Flags: needinfo?(tnikkel)
Flags: needinfo?(mstange)
Flags: needinfo?(bgrinstead)
Blocks: 1158872
(In reply to :Gijs Kruitbosch from comment #6)
> Brian, looks like changing the accentcolor regressed this. Reverting that
> change fixes this issue...

I'll take a look.  Sounds like an issue with the lightweight theming system.  I guess as a workaround we could only set the accentcolor in windows (since it's the only platform that needs the transparent background on the root element.
(In reply to Brian Grinstead [:bgrins] from comment #7)
> (In reply to :Gijs Kruitbosch from comment #6)
> > Brian, looks like changing the accentcolor regressed this. Reverting that
> > change fixes this issue...
> 
> I'll take a look.  Sounds like an issue with the lightweight theming system.
> I guess as a workaround we could only set the accentcolor in windows (since
> it's the only platform that needs the transparent background on the root
> element.

Indeed. Part of me would prefer to figure out why this is breaking things on OS X...
(In reply to :Gijs Kruitbosch from comment #8)
> (In reply to Brian Grinstead [:bgrins] from comment #7)
> > (In reply to :Gijs Kruitbosch from comment #6)
> > > Brian, looks like changing the accentcolor regressed this. Reverting that
> > > change fixes this issue...
> > 
> > I'll take a look.  Sounds like an issue with the lightweight theming system.
> > I guess as a workaround we could only set the accentcolor in windows (since
> > it's the only platform that needs the transparent background on the root
> > element.
> 
> Indeed. Part of me would prefer to figure out why this is breaking things on
> OS X...

I would have to imagine any lightweight theme using a transparent (or maybe even semitransparent) accentcolor will have this issue.  I can't reproduce on 10.10 and don't have a dev environment set up with 10.9.  I can proceed with preprocessing the accentcolor for Windows only, but that's the best I can think of right now (unless if there is a way to repro on 10.10)
Flags: needinfo?(bgrinstead)
Assignee: nobody → bgrinstead
Status: NEW → ASSIGNED
Comment on attachment 8602780 [details] [diff] [review]
accentcolor.patch

Review of attachment 8602780 [details] [diff] [review]:
-----------------------------------------------------------------

rs=me but please file a separate Core :: Widget: cocoa bug about the transparent accentcolor causing issues on OS X, and cc me and needinfo mstange there. :-)
Attachment #8602780 - Flags: review+
Please do :-)
remote:   https://hg.mozilla.org/integration/fx-team/rev/067e21985d8d
Whiteboard: [fixed-in-fx-team]
See Also: → 1162649
https://hg.mozilla.org/mozilla-central/rev/067e21985d8d
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Whiteboard: [fixed-in-fx-team]
Target Milestone: --- → mozilla40
You need to log in before you can comment on or make changes to this bug.