Closed Bug 1162620 Opened 5 years ago Closed 5 years ago

Visited link on about:crashes isn't purple anymore

Categories

(Toolkit :: Themes, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla40
Tracking Status
firefox40 --- fixed

People

(Reporter: guijoselito, Assigned: Paenglab)

References

Details

(Keywords: regression)

Attachments

(1 file, 2 obsolete files)

After bug 1161161, all the links (visited and not visited) are blue. Without color indication it's harder to know which crashes have been investigated/visited/submitted. I'm on Windows 7 (don't know if the problem happens on all platforms).
It happens on all platforms.  :(  This basically makes about:crashes useless for people who want to stay on top of the crashes they've encountered.  Can we fix this, please?
Attached patch Bug1162620.patch (obsolete) — Splinter Review
This adds the the default color for visited links to crashes.xhtml.
Assignee: nobody → richard.marti
Status: NEW → ASSIGNED
Attachment #8602985 - Flags: review?(dao)
Comment on attachment 8602985 [details] [diff] [review]
Bug1162620.patch

I'm pretty sure this belongs in common.inc.css, and you don't want to use a platform color for this since the background color is hardcoded.
Attachment #8602985 - Flags: review?(dao) → review-
Attached patch Bug1162620.patch (obsolete) — Splinter Review
I wasn't sure if the other in-content pages also want the visited state but this should help the user to know what he already has seen.

I'm using the default visited color from about:config, is this okay?
Attachment #8602985 - Attachment is obsolete: true
Attachment #8603222 - Flags: review?(dao)
Comment on attachment 8603222 [details] [diff] [review]
Bug1162620.patch

:visited won't work for .text-link and .inline-link, since those aren't real links. r=me with these two lines removed
Attachment #8603222 - Flags: review?(dao) → review+
Attached patch Bug1162620.patchSplinter Review
Fixed comment.

Carrying over r+
Attachment #8603222 - Attachment is obsolete: true
Attachment #8603228 - Flags: review+
Keywords: checkin-needed
Thanks for the quick fix!
https://hg.mozilla.org/mozilla-central/rev/3e85a97162d9
Status: ASSIGNED → RESOLVED
Closed: 5 years ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla40
QA Whiteboard: [good first verify]
I have seen this bug on Firefox nightly (20150507) on windows 8.1(32bit).

Build ID 	20150507030203
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:40.0) Gecko/20100101 Firefox/40.0


Latest Firefox beta & nightly showed blue color for uninvited link & purple color for visited link.
Latest Firefox  nightly:

Build ID 	20150721030212
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:42.0) Gecko/20100101 Firefox/42.0

Latest Firefox beta:

Build ID 	20150720220238
User Agent 	Mozilla/5.0 (Windows NT 6.3; rv:40.0) Gecko/20100101 Firefox/40.0


[bugday-20150722]
QA Whiteboard: [good first verify] → [good first verify][bugday-20150722]
You need to log in before you can comment on or make changes to this bug.