Network waterfall shows blocked requests starting too early.

RESOLVED INACTIVE

Status

()

Firefox
Developer Tools: Netmonitor
RESOLVED INACTIVE
3 years ago
3 days ago

People

(Reporter: canuckistani, Unassigned)

Tracking

40 Branch
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

Attachments

(2 attachments)

Created attachment 8603015 [details]
jgjgcfjh.png

Reported via private email:

"Here's the test page with one 10-second stylesheet followed by six 2-second images.
    http://stevesouders.com/cuzillion/?c0=hc1hfff10_0_f&c1=bi1hfff2_0_f&c2=bi1hfff2_0_f&c3=bi1hfff2_0_f&c4=bi1hfff2_0_f&c5=bi1hfff2_0_f&c6=bi1hfff2_0_f

WebPageTest and my webserver logs (see below) confirm that none of the images are requested until AFTER the stylesheet is done downloading. However, the Firefox waterfall incorrectly shows the first five images downloading in the first two seconds. Those first five images should have a horizontal bar like the sixth image where it blocks for 10 seconds and then the download occurs between 10-12 seconds."
Created attachment 8603023 [details]
chrome's waterfall for comparison

Comment 2

3 days ago
Per policy at https://wiki.mozilla.org/Bug_Triage/Projects/Bug_Handling/Bug_Husbandry#Inactive_Bugs. If this bug is not an enhancement request or a bug not present in a supported release of Firefox, then it may be reopened.
Status: NEW → RESOLVED
Last Resolved: 3 days ago
Resolution: --- → INACTIVE
You need to log in before you can comment on or make changes to this bug.