Firefox Developer Edition appname.bmp is too small

VERIFIED FIXED in Firefox 40

Status

()

defect
VERIFIED FIXED
4 years ago
4 years ago

People

(Reporter: rstrong, Assigned: rstrong)

Tracking

unspecified
Firefox 41
Points:
---
Bug Flags:
in-testsuite -

Firefox Tracking Flags

(firefox38 unaffected, firefox38.0.5 unaffected, firefox39 unaffected, firefox40 fixed, firefox41 verified)

Details

Attachments

(4 attachments, 3 obsolete attachments)

I just noticed that the image for aurora is quite small when compared to the one in nightly. Due to the additional colors on the intro page for Nightly and Aurora these appname.bmp dimensions need to be 4 times the result dimensions to blend properly as we found out when the stub was first implemented. I've attached a sample using the nightly bitmap with additional space below it for "Developer Edition"
Posted patch patch sample (obsolete) — Splinter Review
shorlander, see comment #0 for an explanation. I think a larger bitmap than in the patch would be appropriate for this.
Attachment #8603073 - Flags: feedback?(shorlander)
Posted patch patch example (obsolete) — Splinter Review
Forgot to update image dimensions for rounding
Attachment #8603073 - Attachment is obsolete: true
Attachment #8603073 - Flags: feedback?(shorlander)
Attachment #8603075 - Flags: feedback?(shorlander)
Posted image screenshot (obsolete) —
screenshot using the patch
Attachment #8603078 - Flags: feedback?(shorlander)
I am fairly certain that this is due to rounding issues and using the smaller dimension bitmap.
As can be seen "Firefox" is larger on the stub in aurora than it is in nightly yet the source bitmap for aurora is smaller than it is in nightly.

Also note how the smaller bitmap on aurora has much larger border edges than used by nightly.
Posted image screenshot hiDPI
Attachment #8603075 - Attachment is obsolete: true
Attachment #8603078 - Attachment is obsolete: true
Attachment #8603075 - Flags: feedback?(shorlander)
Attachment #8603078 - Flags: feedback?(shorlander)
I'm certain more could be done but I think this is good enough. Specifically, appname.bmp could have edges that are closer to the intro page color but then the background of the download / install page would need to be changed to a color closer to he background of the intro page and the other bitmaps on the download / install page would need their edges changes to a color closer to that same color. Basically what we have on the other channels.
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Comment on attachment 8603130 [details] [diff] [review]
patch

Review of attachment 8603130 [details] [diff] [review]:
-----------------------------------------------------------------

LGTM
Attachment #8603130 - Flags: review?(shorlander) → review+
Flags: in-testsuite-
Target Milestone: --- → Firefox 41
https://hg.mozilla.org/mozilla-central/rev/9d1d3ff003a2
Status: ASSIGNED → RESOLVED
Closed: 4 years ago
Resolution: --- → FIXED
Comment on attachment 8603130 [details] [diff] [review]
patch

Approval Request Comment
[Feature/regressing bug #]: ever since the Firefox Developer Edition release
[User impact if declined]: Poor looking stub installer image
[Describe test coverage new/current, TreeHerder]: None
[Risks and why]: Next to none. This just replaces the graphic with dimensions.
[String/UUID change made/needed]: None
Attachment #8603130 - Flags: approval-mozilla-aurora?
BTW: this image isn't used in Nightly so its affect will only be seen on Aurora
Attachment #8603130 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
I have successfully reproduced this bug on Firefox aurora 39.0a2 (2015-05-07)

I found this fix on latest Firefox aurora 41.0a2 (2015-07-31) 

Build ID : 20150731004008
Mozilla/5.0 (Windows NT 10.0; Win64; x64; rv:41.0) Gecko/20100101 Firefox/41.0

[bugday-20150729]
Thanks Rezaul Huque Nayeem!

Marking as verified fixed based on your testing.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.