SVG is cropped when drop-shadow CSS filter is applied

RESOLVED DUPLICATE of bug 1153845

Status

()

RESOLVED DUPLICATE of bug 1153845
4 years ago
4 years ago

People

(Reporter: vladimirs, Assigned: mstange)

Tracking

37 Branch
mozilla41
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_1) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36

Steps to reproduce:

1. Create an inline SVG with viewBox="0 0 115 190"
2. Set the width of the SVG in CSS to be larger than the viewBox width: svg {width: 200px;}
3. Add CSS drop-shadow filter: filter: drop-shadow(0px 0 5px #000);

Here's a demo:
http://jsbin.com/ponukolopu/1/edit?html,css,output


Actual results:

SVG image is cropped.


Expected results:

SVG image should not be cropped. Chrome and Safari are not cropping the image.
(Assignee)

Comment 1

4 years ago
This may be the same as bug 1153845.
Assignee: nobody → mstange
Status: UNCONFIRMED → ASSIGNED
Ever confirmed: true
(Assignee)

Comment 2

4 years ago
Looks like bug 1153845 fixed this.
Status: ASSIGNED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → DUPLICATE
Target Milestone: --- → mozilla41
Duplicate of bug: 1153845
You need to log in before you can comment on or make changes to this bug.