All users were logged out of Bugzilla on October 13th, 2018

Contacts can't handle people with only a first name when order by last name is on

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: dave, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

4 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

Have some contacts, some with only first names.
Change sort order to by last name.


Actual results:

The contact list gets truncated. (You may have to kill Contacts and open it again in order to see it)
The delete contacts UI does not fully appear.
No contacts can be viewed.


Expected results:

On users without a last name, the first name should be used for sorting.
Can you tell us which version of gecko and gaia are you using?
Flags: needinfo?(dave)
(Reporter)

Comment 2

4 years ago
Sorry for the oversight. I'm running 3.0.0-prerelease, and haven't tested it on other versions.
Flags: needinfo?(dave)
QA wanted for a branch check.
Keywords: qawanted
QA Contact: ychung
I saw some issues on the build closer to the reported build. Contacts disappeared from the list when changing back and forth between "Order by last name" option on and off:

Environmental Variables:
Device: Flame 3.0
BuildID: 20150415123418
Gaia: 777d01f4a2c7b41c4b02e3cf87715714ccc0590b
Gecko: 53ceefb0e1c8
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0


However, latest Flame 3.0 and 2.2 do not have any problem when switching between "Order by last name" option on and off. Note that the reported build is about a month old.

Environmental Variables:
Device: Flame 3.0
BuildID: 20150510184409
Gaia: 6089234ace8b294a8feef064387604bae16254e3
Gecko: d8420a541d1c
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Environmental Variables:
Device: Flame 2.2
BuildID: 20150511034732
Gaia: 6d7981e1b6be2992ab4842065859270b4a62a4bd
Gecko: 755ff2baa2c9
Version: 37.0 (2.2) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
Keywords: qawanted
QA Contact: ychung
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker)
(Reporter)

Comment 5

4 years ago
Great. I haven't gotten a newer build yet so I haven't been able to test this, but I trust that it has been fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → INVALID
Moving to "works for me", the issue was real but has been fixed since.
Resolution: INVALID → WORKSFORME
You need to log in before you can comment on or make changes to this bug.