bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

Firefox fails to open a page when using profiles and starting the program

RESOLVED INCOMPLETE

Status

()

Firefox
Shell Integration
RESOLVED INCOMPLETE
3 years ago
a year ago

People

(Reporter: lorenzo, Unassigned)

Tracking

37 Branch
x86
Mac OS X
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10_10_3) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.90 Safari/537.36

Steps to reproduce:

Firefox is closed.
I open a link from another program (say, NetNewsWire).
The "Choose user profile" window appears, as I have configured some profiles.
I pick my chosen profile for the link I want to see. I do not have a default profile nor do I want to set one.




Actual results:

Firefox opens my start page (set to blank) but does not open the link I clicked.


Expected results:

Firefox should have opened the link I clicked.

Comment 1

3 years ago
(In reply to lorenzo from comment #0)
> I do not have a default profile nor do I want to set one.

The default profile is simply the last profile used. So if you've started Firefox at least once, you have a default profile.

> Firefox is closed.
> I open a link from another program (say, NetNewsWire).
> The "Choose user profile" window appears, as I have configured some profiles.
> I pick my chosen profile for the link I want to see.

Works for me in Windows 7 and Linux Mint KDE 17.1. I also tried editing profiles.ini to strip out the Default=1 line.

Mozilla/5.0 (X11; Ubuntu; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Version: 37.0.2
Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Version: 37.0.2
Component: Untriaged → Shell Integration
OS: Unspecified → Mac OS X
Hardware: Unspecified → x86
Do you still see this problem whne using a current version?
Flags: needinfo?(lorenzo.grespan)
Whiteboard: [closeme 2017-06-15]

Comment 3

a year ago
Resolved per whiteboard
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Flags: needinfo?(lorenzo.grespan)
Resolution: --- → INCOMPLETE
Whiteboard: [closeme 2017-06-15]
You need to log in before you can comment on or make changes to this bug.