If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Email]When user cancels the operation of marking 2 mails(1 read and 1 unread) as unread, the original unread mail will be marked as read.

RESOLVED DUPLICATE of bug 997496

Status

Firefox OS
Gaia::E-Mail
RESOLVED DUPLICATE of bug 997496
3 years ago
3 years ago

People

(Reporter: SandKing, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [2.2-nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
[1.Description]:
[Nexus 5][v2.2&3.0][Flame][v2.2&3.0][Email]If we check a read and another unread email and mark them as read emails, but then cancle this operation, the unread email will be marked as read.
Found Time: 15:21
See log:"logcat_1521.txt"
See video:"1521.mp4"

[2.Testing Steps]: 
Premise: An email account which has lots of  unread and read mails is logged in device.
1. Launch Email.
2. At "Inbox" view, tap the "check" button at bottom-right.
3. Check an unread mail and a read mail.
4. Tap the "unread" icon to mark this two mail as "unread".
5. Tap the "revoke" icon to cancel the current operation.

[3.Expected Result]: 
5. The two emails should keep its original state.

[4.Actual Result]: 
5. You can see that the unread  mail will be mark as a read mail.

[5.Reproduction build]: 

Flame 2.2(Affected):
Build ID               20150507002500
Gaia Revision          83a63e0e6fcc22c6a74b06ef77b88d5049719cad
Gaia Date              2015-05-07 00:17:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/118ddfc76b60
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.041847
Firmware Date          Thu May  7 04:18:59 EDT 2015
Bootloader             L1TC000118D0

Flame3.0(Affected):
Build ID               20150507160204
Gaia Revision          bc5bfa18f795919b56b952bbf3637c235d0e13dc
Gaia Date              2015-05-07 13:18:34
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5e02da1141d2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.193314
Firmware Date          Thu May  7 19:33:24 EDT 2015
Bootloader             L1TC000118D0

Nexus5_2.2(Affected):
Build ID               20150507162502
Gaia Revision          fa88af3a8e175be6a35ddd3e88b4446976027894
Gaia Date              2015-05-07 22:06:25
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/006e0cf17e6f
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150507.194838
Firmware Date          Thu May  7 19:48:53 EDT 2015
Bootloader             HHZ12f

Nexus5_3.0(Affected):
Build ID               20150507160204
Gaia Revision          bc5bfa18f795919b56b952bbf3637c235d0e13dc
Gaia Date              2015-05-07 13:18:34
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5e02da1141d2
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150507.192329
Firmware Date          Thu May  7 19:23:43 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test
(Reporter)

Comment 1

3 years ago
Created attachment 8603264 [details]
Bug log: logcat_1521.txt
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
(Reporter)

Comment 2

3 years ago
Created attachment 8603265 [details]
Bug video: 1521.mp4
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 997496
You need to log in before you can comment on or make changes to this bug.