[Flame][Dialer]All missed calls of two SIM cards will be shown as one record, and you can't recognize which SIM Card every miss call is from.

RESOLVED INVALID

Status

Firefox OS
Gaia::Dialer
RESOLVED INVALID
3 years ago
3 years ago

People

(Reporter: sunny, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(b2g-v2.2 affected, b2g-master affected)

Details

Attachments

(2 attachments)

510.15 KB, text/plain
Details
4.06 MB, video/mp4
Details
(Reporter)

Description

3 years ago
Created attachment 8603263 [details]
logcat_1729.txt

[1.Description]:
[Flame v2.2 & v3.0][Dialer]The device has two SIM cards at same time. If you launch dialer app to see miss calls, you will find that all missed calls of two SIM cards will be shown as one record. You can't recognize that every miss call is from which SIM Card .
 
Time:17:29
See attachment 1729 [details].mp4 and logcat_1729.txt

[2.Testing Steps]: 
Precondition: The device has two SIM cards at same time.
1.Use another device to call SIM1, and hang it up.
2.Use another device to call SIM2, and hang it up.
3.Launch dialer app , and long tap the miss calls.

[3.Expected Result]: 
3.All miss calls of a phone number are showed separately, and can recognize which SIM Card every miss call is from

[4.Actual Result]: 
3.All miss calls of a phone number are showed together, and can't recognize which SIM Card every miss call is from

[5.Reproduction build]: 
Flame 2.2 version(Affected):
Build ID               20150507002500
Gaia Revision          83a63e0e6fcc22c6a74b06ef77b88d5049719cad
Gaia Date              2015-05-07 00:17:17
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/118ddfc76b60
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.041847
Firmware Date          Thu May  7 04:18:59 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 version(Affected):
Build ID               20150507160204
Gaia Revision          bc5bfa18f795919b56b952bbf3637c235d0e13dc
Gaia Date              2015-05-07 13:18:34
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/5e02da1141d2
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150507.193314
Firmware Date          Thu May  7 19:33:24 EDT 2015
Bootloader             L1TC000118D0


[6.Reproduction Frequency]: 
Always Recurrence,10/10

[7.TCID]: 
Free Test

[8.Note]:
Same thing will happen, if you use the device to dial same phone number from two SIM cards.
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected

Comment 1

3 years ago
Created attachment 8603282 [details]
1729.mp4
This behavior is by design, see bug 947131 comment 3.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.