ReaderModeBar not kept in sync with article changes

RESOLVED FIXED

Status

()

Firefox for iOS
Reader View
RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: aaronmt, Assigned: st3fan)

Tracking

unspecified
ARM
iOS

Firefox Tracking Flags

(fennec+)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Currently when one removes an added item in the reading list, we do not reflect the change back in reader view if the article is still up (e.g, cancelling out and returning to the view). The trash-can is still visible. It should return to 'Add to Reading List'.
(Reporter)

Comment 1

3 years ago
Also this state is persistent in that for each new article viewed in reader-view, the trash-can will always be visible thus preventing the user from adding a new article to their list.
(Reporter)

Updated

3 years ago
Summary: Removing a reader item from the reading list does not reflect status in the reading view → Removing a reader item from the reading list does not reflect status in the reading view; state is also persistent for all additional reader view content
(Reporter)

Updated

3 years ago
See Also: → bug 1162734
Assignee: nobody → sarentz
tracking-fennec: ? → +
(Assignee)

Updated

3 years ago
Summary: Removing a reader item from the reading list does not reflect status in the reading view; state is also persistent for all additional reader view content → ReaderModeBar not kept in sync with article changes
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1162995
(Assignee)

Updated

3 years ago
Duplicate of this bug: 1162734
(Assignee)

Comment 4

3 years ago
Created attachment 8604829 [details] [review]
PR: https://github.com/mozilla/firefox-ios/pull/453
Attachment #8604829 - Flags: review?(sleroux)
Comment on attachment 8604829 [details] [review]
PR: https://github.com/mozilla/firefox-ios/pull/453

I'm assuming the issue was only when we were leaving the home panel? Looks good!
Attachment #8604829 - Flags: review?(sleroux) → review+
(Assignee)

Comment 6

3 years ago
Merged.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.