Closed Bug 1163058 Opened 5 years ago Closed 5 years ago

[Browser][YouTube] Youtube video appears black while video plays, but audio can be heard

Categories

(Firefox OS Graveyard :: Gaia::Browser, defect)

ARM
Gonk (Firefox OS)
defect
Not set

Tracking

(blocking-b2g:2.5+, b2g-v2.2 unaffected, b2g-master affected)

RESOLVED DUPLICATE of bug 1139276
blocking-b2g 2.5+
Tracking Status
b2g-v2.2 --- unaffected
b2g-master --- affected

People

(Reporter: dharris, Assigned: bwu)

References

()

Details

(Keywords: regression, Whiteboard: [3.0-Daily-Testing][systemsfe])

Attachments

(1 file)

Description:
If the user returns to the homescreen while they are watching a video on youtube, the video will appear all black. Scrubbing through the video will only show a black screen, and the only way to remedy this issue is to either refresh the page, or open up a new video.


Repro Steps:
1) Update a Flame to 20150508010203
2) Open Browser> Navigate to Youtube.com
3) Play any video> Select another video below
4) Tap home button while video is playing
5) Long press home button to access card view> Select browser tab with youtube video


Actual:
The video pauses when the user returns home, but when going back to the youtube video the video resumes and audio plays correctly, but the video displays as all black. The only way to get back the picture for the video is to refresh the page


Expected:
The audio and video resume and can be seen and heard without issue

Environmental Variables:
Device: Flame 3.0 (319mb)(Kitkat)(Full Flash)
Build ID: 20150508010203
Gaia: bc5bfa18f795919b56b952bbf3637c235d0e13dc
Gecko: 356e735fa908
Gonk: a9f3f8fb8b0844724de32426b7bcc4e6dc4fa2ed
Version: 40.0a1 (Master)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Repro frequency: 9/10
See attached: Logcat, Video - https://youtu.be/qn_P7z2T3wc
This issue does NOT occur on Flame 2.2

The audio and video resume and can be seen and heard without issue

Environmental Variables:
Device: Flame 2.2 (319mb)(Kitkat)(Full Flash)
Build ID: 20150508002501
Gaia: 88d3ac2721a5484495c2ed60e4a068945f0de5aa
Gecko: 8ad16ebe659d
Gonk: ab265fb203390c70b8f2a054f38cf4b2f2dad70a
Version: 37.0 (2.2)
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:37.0) Gecko/37.0 Firefox/37.0
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(pbylenga)
Also this seems to be a similar issue to bug 1158659. However, in this bug the video will always resume, and in bug 1158659 the video does not resume playing
QA Contact: jmercado
The initial window is very familiar with and has bug 1146729 in it.  Going into the inbound now, but likely won't finish til Monday.

Central Regression Window:

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150427033459
Gaia: 581df5e5cad323e811fffef69553278c1fb695a4
Gecko: 9c22b105b0e3
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150427121519
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: caf25344f73e
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working gaia / First Broken gecko - Issue Does occur
Gaia: 581df5e5cad323e811fffef69553278c1fb695a4
Gecko: caf25344f73e

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: 0636405f0844bf32451a375b2d61a2b16fe33348
Gecko: 9c22b105b0e3

Gaia Pushlog: http://hg.mozilla.org/mozilla-central/pushloghtml?fromchange=9c22b105b0e3&tochange=caf25344f73e
Flags: needinfo?(ktucker)
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
The changes for Bug 1146729 seem to have caused this issue.  Please see the pushlog.

Mozilla-inbound Regression Window

Last Working 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150427015253
Gaia: b4c949cdc780893897c9b45c1adea46e2eb694ff
Gecko: fe832ef6cc60
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

First Broken 
Environmental Variables:
Device: Flame 3.0
BuildID: 20150427020457
Gaia: b4c949cdc780893897c9b45c1adea46e2eb694ff
Gecko: 5fa88d413c4f
Gonk: Could not pull gonk.  Did you shallow Flash?
Version: 40.0a1 (3.0) 
Firmware Version: v18D-1
User Agent: Mozilla/5.0 (Mobile; rv:40.0) Gecko/40.0 Firefox/40.0

Last Working gaia / First Broken gecko - Issue DOES occur
Gaia: b4c949cdc780893897c9b45c1adea46e2eb694ff
Gecko: 5fa88d413c4f

First Broken gaia / Last Working gecko - Issue does NOT occur
Gaia: b4c949cdc780893897c9b45c1adea46e2eb694ff
Gecko: fe832ef6cc60

Gecko Pushlog: 
http://hg.mozilla.org/integration/mozilla-inbound/pushloghtml?fromchange=fe832ef6cc60&tochange=5fa88d413c4f
QA Whiteboard: [QAnalyst-Triage?]
Flags: needinfo?(ktucker)
[Blocking Requested - why for this release]:

This issue could impact multiple end users since it involves Youtube. The video should always play correctly without issue so nominating 3.0?

Blake, can you take a look at this please? Looks like another fallout from the landing for bug 1146729.
Blocks: 1146729
blocking-b2g: --- → 3.0?
QA Whiteboard: [QAnalyst-Triage?] → [QAnalyst-Triage+]
Flags: needinfo?(ktucker) → needinfo?(bwu)
Flags: needinfo?(pbylenga)
Sure. I will check it. Thanks for this info.
Assignee: nobody → bwu
Flags: needinfo?(bwu)
This is not caused by bug 1146729 and is duplicate of bug 1139276.
No longer blocks: 1146729
Status: NEW → RESOLVED
Closed: 5 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1139276
blocking-b2g: 3.0? → 3.0+
You need to log in before you can comment on or make changes to this bug.