Romanian diacritics have different font on Google and Facebook.

RESOLVED WORKSFORME

Status

()

Core
Layout: Text
RESOLVED WORKSFORME
3 years ago
3 years ago

People

(Reporter: lennydegg, Unassigned)

Tracking

({fonts})

37 Branch
fonts
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8603473 [details]
Capture.PNG

User Agent: Mozilla/5.0 (Windows NT 6.1; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Updated

3 years ago
Component: Untriaged → Layout: Text
Keywords: fonts
Product: Firefox → Core

Comment 1

3 years ago
Created attachment 8603493 [details]
works for me.png

Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
Version: 37.0.2

Works for me. I tried with hardware acceleration on, then off, and there was no issue either way.

Does the text display correctly in a brand new profile?
https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-profiles

Do other browsers display the text correctly? If not, your copy of the Arial font may be corrupt.
https://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/all-browsers-are-having-corrupted-arial-font/1eae289a-dd2a-46f3-94eb-20752155d281
Flags: needinfo?(lennydegg)

Updated

3 years ago
See Also: → bug 1163654
(Reporter)

Comment 2

3 years ago
(In reply to Gingerbread Man from comment #1)
> Created attachment 8603493 [details]
> works for me.png
> 
> Mozilla/5.0 (Windows NT 6.1; WOW64; rv:37.0) Gecko/20100101 Firefox/37.0
> Version: 37.0.2
> 
> Works for me. I tried with hardware acceleration on, then off, and there was
> no issue either way.
> 
> Does the text display correctly in a brand new profile?
> https://support.mozilla.org/kb/profile-manager-create-and-remove-firefox-
> profiles
> 
> Do other browsers display the text correctly? If not, your copy of the Arial
> font may be corrupt.
> https://answers.microsoft.com/en-us/ie/forum/ie8-windows_other/all-browsers-
> are-having-corrupted-arial-font/1eae289a-dd2a-46f3-94eb-20752155d281

Sorry for not clearing up your questions. Your first solution didn't work. I'd try to reinstall the Arial font, but I don't know how.
Flags: needinfo?(lennydegg)

Comment 3

3 years ago
(In reply to lennydegg from comment #2)
> Sorry for not clearing up your questions.

Could you please check if the text displays correctly in Internet Explorer? (I know said “browsers” earlier, but Chrome and Opera perform normalization, so the results may not be comparable.)

> I'd try to reinstall the Arial font, but I don't know how.

Did you try the directions in the Microsoft Answers thread I linked to above? Two people there reported that it worked for them.
1. Log in to Windows with an administrator account.
2. Click the Windows logo orb on the taskbar to bring up the Start Menu.
3. In the Search box, type the following, then press Enter:
C:\Windows\Fonts\Arial.ttf
4. In the Arial window that opens, click the Install button.
(Reporter)

Comment 4

3 years ago
 > Could you please check if the text displays correctly in Internet Explorer? (I know said “browsers” earlier, but Chrome and Opera perform normalization, so the results may not be comparable.)

Indeed, the characters display correctly in Internet Explorer. (I don't know how to include an attachment in this reply)

 > Did you try the directions in the Microsoft Answers thread I linked to above? Two people there reported that it worked for them.
1. Log in to Windows with an administrator account.
2. Click the Windows logo orb on the taskbar to bring up the Start Menu.
3. In the Search box, type the following, then press Enter:
C:\Windows\Fonts\Arial.ttf
4. In the Arial window that opens, click the Install button.

By doing that it just opens a Notepad window with indistinguishable characters.

Comment 5

3 years ago
(In reply to lennydegg from comment #4)
> By doing that it just opens a Notepad window with indistinguishable
> characters.

That suggests a registry problem with the association for TTF files. Try this:

1. Download the European Union Expansion Font Update, but don't run the setup file.
http://www.microsoft.com/en-us/download/details.aspx?id=16083
2. Launch an archiving utility like WinRAR (http://rarlab.com).
3. In the archiving utility's file listing, navigate to EUupdate.EXE and double-click to open it as an archive.
4. Extract Arial.ttf, ArialBd.ttf, ArialBI.ttf and ArialI.ttf to a new folder on the desktop.
5. Click the Windows logo orb on the taskbar to bring up the Start Menu.
6. In the Search box, type fonts then press Enter. This should open a Control Panel window in the Fonts category.
7. Drag all the files you extracted earlier onto this window.
8. At the Install Font prompt, check “Do this for all current items” then click the Yes button.
9. If Firefox is currently running, restart it.

If that doesn't help, we can rule out the corrupt font theory.
(Reporter)

Comment 6

3 years ago
(In reply to Gingerbread Man from comment #5)
> (In reply to lennydegg from comment #4)
By doing that it just opens a Notepad window with indistinguishable
characters.
That suggests a registry problem with the association for TTF files. Try
this:

1. Download the European Union Expansion Font Update, but don't run the
setup file.
http://www.microsoft.com/en-us/download/details.aspx?id=16083
2. Launch an archiving utility like WinRAR (http://rarlab.com).
3. In the archiving utility's file listing, navigate to EUupdate.EXE and
double-click to open it as an archive.
4. Extract Arial.ttf, ArialBd.ttf, ArialBI.ttf and ArialI.ttf to a new
folder on the desktop.
5. Click the Windows logo orb on the taskbar to bring up the Start Menu.
6. In the Search box, type fonts then press Enter. This should open a
Control Panel window in the Fonts category.
7. Drag all the files you extracted earlier onto this window.
8. At the Install Font prompt, check “Do this for all current items” then
click the Yes button.
9. If Firefox is currently running, restart it.

If that doesn't help, we can rule out the corrupt font theory.

I don't know how to thank you enough for this, it finally fixed it!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME

Comment 7

3 years ago
(In reply to lennydegg from comment #6)
> I don't know how to thank you enough for this, it finally fixed it!

You're welcome. Can you please confirm that the issue in bug 1163654 is gone as well?
Flags: needinfo?(lennydegg)

Updated

3 years ago
Duplicate of this bug: 1163654

Updated

3 years ago
Flags: needinfo?(lennydegg)
See Also: bug 1163654
You need to log in before you can comment on or make changes to this bug.