De-duplicate document titles

RESOLVED FIXED

Status

P2
normal
RESOLVED FIXED
4 years ago
3 years ago

People

(Reporter: peterbe, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(firefox40 affected)

Details

Attachments

(2 attachments)

(Reporter)

Description

4 years ago
We have a lot of pages with the exact same document title. E.g. 
https://air.mozilla.org/mozilla-weekly-project-meeting-20140617/ and
https://air.mozilla.org/mozilla-weekly-project-meeting-20141124/

When we put the `{{ event.title }}` in the page title, we ought to check if it's a non-unique title and if it is include the event_time in a nice way.
Why?  Don't they sort by date when presented?
(Reporter)

Comment 2

3 years ago
It's when viewing individual pages. For the example, it becomes impossible to see which one you have open if you look at your tabs or browser history if it's just called "Engineering Meeting".
Priority: -- → P2
(Reporter)

Comment 3

3 years ago
Let's start with 

1) the <title> tag

2) the event tweet text

NB: This only applies if the title is currently not unique.
(Reporter)

Comment 4

3 years ago
Actually, the event tweet text is based on the short description or description. 
What about when you search? Do we want to use it there and then? I think so. Because that's a place where it's possible to list those with the same title next to each other.

Comment 5

3 years ago
Commits pushed to master at https://github.com/mozilla/airmozilla

https://github.com/mozilla/airmozilla/commit/13f276f715b952ed1b5a25f207926552fc8ac166
fixes bug 1163134 - De-duplicate document titles

https://github.com/mozilla/airmozilla/commit/3cfd7f9ac519517e85b32ea2e9d0bbb405d7636b
Merge pull request #526 from peterbe/bug-1163134-de-duplicate-document-titles

fixes bug 1163134 - De-duplicate document titles

Updated

3 years ago
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 6

3 years ago
This can cause UnicodeEncodeErrors
https://errormill.mozilla.org/webtools/airmozilla-dev/group/400527/
Able to reproduce it locally.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 8

3 years ago
Commits pushed to master at https://github.com/mozilla/airmozilla

https://github.com/mozilla/airmozilla/commit/9609824ac5b1c4df97a9dbdc98ec6e901382055a
fixes bug 1163134 - fix UnicodeEncodeError on get_unique_title

https://github.com/mozilla/airmozilla/commit/659927c1bb89ad3f515e3c5d8650fa910853c513
Merge pull request #527 from peterbe/bug-1163134-fix-unicodeencodeerror-on-get_unique_title

fixes bug 1163134 - fix UnicodeEncodeError on get_unique_title
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

3 years ago
We should do this on RSS feeds too.
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 11

3 years ago
Commits pushed to master at https://github.com/mozilla/airmozilla

https://github.com/mozilla/airmozilla/commit/4e2ae0c65bfe9813106363e91737c25040baa815
fixes bug 1163134 - de-dupliate titles on feeds

https://github.com/mozilla/airmozilla/commit/c220dc899d0095e8752dfad2692da8041db992ce
Merge pull request #531 from peterbe/bug-1163134-de-dupliate-titles-on-feeds

fixes bug 1163134 - de-dupliate titles on feeds

Updated

3 years ago
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.