Consider refactoring ``text_log_summary`` and ``Bug suggestions`` artifacts

RESOLVED DUPLICATE of bug 1078450

Status

Tree Management
Treeherder
RESOLVED DUPLICATE of bug 1078450
3 years ago
2 years ago

People

(Reporter: camd, Unassigned)

Tracking

Details

(Reporter)

Description

3 years ago
A few issues here:
1. We have duplicated data in the different artifacts
2. text_log_summary has a "header" field that could be removed.  We should get that data from the job object itself.

The "all_errors" values in the blob of the ``text_log_summary`` are duplicated in 3 places:

1. the "all_errors" field
2. the step where the errors came from (possibly multiple steps, but not usually)
3. the ``Bug suggestions`` artifact.

In the process of doing this, we may want to create some kind of "Status" for bug suggestions that indicate we need the artifact.  Currently we just save a "blank" one with an empty array, which indicates there are no error lines that needed them, but that we checked for them.
(Reporter)

Comment 1

3 years ago
Adding Ed, because we chatted about this and agreed this was a good idea.

Updated

2 years ago
Status: NEW → RESOLVED
Last Resolved: 2 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1078450
You need to log in before you can comment on or make changes to this bug.