When using Edit>Find on a particular webpage, the wrong text is highlighted

RESOLVED DUPLICATE of bug 806146

Status

()

Firefox
PDF Viewer
RESOLVED DUPLICATE of bug 806146
3 years ago
3 years ago

People

(Reporter: d_friedman, Unassigned)

Tracking

37 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

3 years ago
Created attachment 8603758 [details]
Firefox find problem.tiff

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

1) I used the Edit>Find feature on this page: http://www.chicagomanualofstyle.org/16/images/ch07_tab01.pdf

2) I entered "mega" into the Find text box.


Actual results:

The text "hyper" was highlighted.  4 matches were found -- all were "hyper", not "mega", which was the term I was searching for.


Expected results:

The text "mega" should have been highlighted.  "mega" appears on the page 4 times, but it was not highlighted.

Additional information: I am using FF 37.0.2 on Mac OS 10.7.5.  I tried to reproduce using another user account (different FF profile) on this same computer, and the same thing happened.

Updated

3 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Component: Untriaged → PDF Viewer
OS: Unspecified → All
Hardware: Unspecified → All
Resolution: --- → DUPLICATE
Duplicate of bug: 806146

Comment 2

3 years ago
Created attachment 8603766 [details]
Firefox find problem.png
Attachment #8603758 - Attachment is obsolete: true
(Reporter)

Comment 3

3 years ago
Hi -- I am the reporter of bug 1163335.  I do not think it is a duplicate of bug 806146.  In my bug, the text that is highlighted when running Find is completely wrong -- it bears no relationship to the text searched for.  This is not merely a problem with font/shifted highlighting (although I agree that perhaps a shift in the highlighted text is also happening.) Please look at the picture I uploaded again -- you will see that though I searched for "mega", "hyper" was highlighted. Thank you.
Comment hidden (spam)

Comment 5

3 years ago
In the example you provided, if you do the reverse and search for hyper, you'll get the same result as in attachment 788700 [details] : parts of words are highlighted with shifted placement. Therefore, I maintain that these are symptoms of the same root cause, and this report is a duplicate.
You need to log in before you can comment on or make changes to this bug.