Unable to edit location of a Bookmark

VERIFIED FIXED in Firefox 40

Status

()

Firefox
Bookmarks & History
VERIFIED FIXED
3 years ago
3 years ago

People

(Reporter: Helge Skjeveland, Assigned: mak)

Tracking

({regression})

40 Branch
Firefox 41
x86_64
Windows 7
regression
Points:
1
Dependency tree / graph
Bug Flags:
firefox-backlog +
in-testsuite ?
qe-verify -

Firefox Tracking Flags

(firefox39 unaffected, firefox40+ verified, firefox41 verified)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
User Agent: Mozilla/5.0 (Windows NT 6.1; Win64; x64; rv:40.0) Gecko/20100101 Firefox/40.0
Build ID: 20150509030210

Steps to reproduce:

Open a bookmarks toolbar menu, and try to edit a bookmark's Properties  | Location there.


Actual results:

The Location field is greyed out, its URI uneditable. One can select the field, arrow through and select in it, but editing is impossible.


Expected results:

The URI should be editable, and saved in its edited form, showing that data when next opened for edit. Name, tags, keywords and description are editable, and edits are saved.
(Reporter)

Comment 1

3 years ago
This looks like a recurrence of my previous bookmarks-location bug.
(Reporter)

Updated

3 years ago
OS: Unspecified → Windows 7
Priority: -- → P1
Hardware: Unspecified → x86_64
(Reporter)

Comment 2

3 years ago
This happens whether bookmark is accessed for edit directly from Bookmarks Toolbar, or via Star drop-down menu.
Component: Untriaged → Toolbars and Customization

Comment 3

3 years ago
[Tracking Requested - why for this release]:
Blocks: 1160864
Status: UNCONFIRMED → NEW
status-firefox40: --- → unaffected
tracking-firefox40: --- → ?
Component: Toolbars and Customization → Bookmarks & History
Ever confirmed: true
Keywords: regression

Updated

3 years ago
status-firefox40: unaffected → affected

Updated

3 years ago
Duplicate of this bug: 1163361

Updated

3 years ago
Flags: needinfo?(mak77)
Priority: P1 → --

Updated

3 years ago
Blocks: 1161882

Comment 5

3 years ago
I can duplicate this error in Firefox nightly 40.0a1 (2015-05-09)
1. Go to Bookmarks > Bookmarks toolbar > Getting started bookmark
2. Right click > properties 
3. Attempt to edit location value (not possible with backslash/delete) and its not possible.
(Assignee)

Comment 6

3 years ago
uoops stupid typo, I put an unwanted "not" there...
this._locationField.readOnly = !this.readOnly;
Assignee: nobody → mak77
Status: NEW → ASSIGNED
Flags: needinfo?(mak77)
(Assignee)

Updated

3 years ago
Points: --- → 1
Flags: qe-verify-
Flags: firefox-backlog+
(Assignee)

Comment 7

3 years ago
Created attachment 8604073 [details] [diff] [review]
patch v1
Attachment #8604073 - Flags: review?(ttaubert)
Attachment #8604073 - Flags: review?(ttaubert) → review+

Updated

3 years ago
Iteration: --- → 40.3 - 11 May

Comment 8

3 years ago
https://hg.mozilla.org/integration/fx-team/rev/f957d54d6a61
https://hg.mozilla.org/mozilla-central/rev/f957d54d6a61
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-firefox41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Firefox 41
(Reporter)

Comment 10

3 years ago
This is NOT fixed as of updating to the 2015-05-12 41.0a1 nightly. A bookmark's URI Location field is STILL greyed out and uneditable.
Status: RESOLVED → REOPENED
Flags: needinfo?(cud)
Resolution: FIXED → ---

Comment 11

3 years ago
(In reply to Helge Skjeveland from comment #10)
> This is NOT fixed as of updating to the 2015-05-12 41.0a1 nightly. A
> bookmark's URI Location field is STILL greyed out and uneditable.

Nightly41.0a1 2015-05-12 does not include the fix yet.

Maybe tomorrow Nightly nightly will include.
Status: REOPENED → RESOLVED
Last Resolved: 3 years ago3 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

3 years ago
Let me know if 2015-05-13 Nightly has the fix for this, and I'll test & verify.
Flags: needinfo?(cud)
Download a hourly build if you are not patient.
status-firefox39: --- → unaffected
Requesting an uplift to Firefox 40
Flags: needinfo?(mak77)

Updated

3 years ago
Duplicate of this bug: 1164118
(Assignee)

Comment 16

3 years ago
Comment on attachment 8604073 [details] [diff] [review]
patch v1

Approval Request Comment
[Feature/regressing bug #]: bookmarks panel rewrite
[User impact if declined]: user can't edit the location of bookmarks
[Describe test coverage new/current, TreeHerder]: Nightly, manual testing
[Risks and why]: low risk oneline typo fix
[String/UUID change made/needed]: none
Flags: needinfo?(mak77)
Attachment #8604073 - Flags: approval-mozilla-aurora?
Duplicate of this bug: 1164125
Summary: Bookmark properties edit is broken again → Unable to edit location of a Bookmark
This is at least the second time we've broken this functionality this year. Does this use case have test coverage to prevent this from regressing yet again?
Flags: in-testsuite?
(Reporter)

Comment 19

3 years ago
Verified fixed in 2015-05-13 41.0a1 Nightly, on Win 7SP1.
Status: RESOLVED → VERIFIED
(Assignee)

Comment 20

3 years ago
bug 1160326 is about having more tests in this area.
tracking-firefox40: ? → +
Comment on attachment 8604073 [details] [diff] [review]
patch v1

Aurora+
Attachment #8604073 - Flags: approval-mozilla-aurora? → approval-mozilla-aurora+
https://hg.mozilla.org/releases/mozilla-aurora/rev/ac30db96aace
status-firefox40: affected → fixed
status-firefox40: fixed → verified
status-firefox41: fixed → verified
You need to log in before you can comment on or make changes to this bug.