Incorrectly formatted error message "sending failed"

RESOLVED FIXED in Thunderbird 41.0

Status

RESOLVED FIXED
3 years ago
3 years ago

People

(Reporter: jorgk, Assigned: rkent)

Tracking

({regression})

38 Branch
Thunderbird 41.0
regression

Thunderbird Tracking Flags

(thunderbird38+ fixed, thunderbird39 fixed, thunderbird40 fixed, thunderbird41 fixed)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
When pressing "Cancel" while e-mail is being sent:

Sending of the message failed.
The message could not be sent using Outgoing server (SMTP) %S for an unknown reason. Please verify that your Outgoing server (SMTP) settings are correct and try again.

%S, hmm, which user would understand this?
(Reporter)

Comment 1

3 years ago
Not dramatic, but also not nice and clearly a regression.
status-thunderbird38: --- → affected
status-thunderbird39: --- → affected
status-thunderbird40: --- → affected
tracking-thunderbird38: --- → ?
Keywords: regression
(Assignee)

Comment 2

3 years ago
Previously, a cancel used the generic message "Sending of the message failed" along with a worthless suggestion to check your settings.

After the big send string reference rewrite, the NS_ERROR_ABORT that comes from the cancel operation was not added to nsComposeStrings.cpp, which means that it falls through to the default message "smtpSendFailedUnknownReason" which includes the %S string.

But the use of that string occurs in DoDeliveryExitProcessing() where again NS_ERROR_ABORT is not handled, and it falls through to the default (which DOES NOT assume that a %S exists in the string).

Really it is a design flaw to fall through in one case to a default that uses %S and in another to one that does not use %S. I am torn about whether to fix that default, or whether to just fix the specific case discovered in this bug. I checked all of the cases that are specifically called out in DoDeliveryExitProcessing and they all have entries defined in nsComposeStrings.cpp  So that means to me that the default string should not require the %S in nsMsgComposeStrings.cpp
(Assignee)

Comment 3

3 years ago
Created attachment 8603776 [details] [diff] [review]
Use generic sendFailed as default message
Attachment #8603776 - Flags: review?(neil)
(Assignee)

Updated

3 years ago
Assignee: nobody → rkent
Status: NEW → ASSIGNED

Updated

3 years ago
Duplicate of this bug: 1160888
(Reporter)

Comment 5

3 years ago
Sorry for reporting a duplicate, but I got more attention than the other guy ;-)

Updated

3 years ago
Attachment #8603776 - Flags: review?(neil) → review+
(Assignee)

Comment 6

3 years ago
http://hg.mozilla.org/comm-central/rev/1bb395cbb279
Status: ASSIGNED → RESOLVED
Last Resolved: 3 years ago
status-thunderbird41: --- → fixed
Resolution: --- → FIXED
Target Milestone: --- → Thunderbird 41.0
(Assignee)

Updated

3 years ago
Attachment #8603776 - Flags: approval-comm-beta?
Attachment #8603776 - Flags: approval-comm-aurora?
(Assignee)

Comment 7

3 years ago
Comment on attachment 8603776 [details] [diff] [review]
Use generic sendFailed as default message

http://hg.mozilla.org/releases/comm-aurora/rev/6198c32a74f7
Attachment #8603776 - Flags: approval-comm-aurora? → approval-comm-aurora+
(Assignee)

Updated

3 years ago
status-thunderbird40: affected → fixed
(Assignee)

Comment 8

3 years ago
Comment on attachment 8603776 [details] [diff] [review]
Use generic sendFailed as default message

TB 39: http://hg.mozilla.org/releases/comm-beta/rev/69ca3c47cce4
TB 38: http://hg.mozilla.org/releases/comm-beta/rev/87ec3c0eb3f0
Attachment #8603776 - Flags: approval-comm-beta? → approval-comm-beta+
(Assignee)

Updated

3 years ago
status-thunderbird38: affected → fixed
status-thunderbird39: affected → fixed
tracking-thunderbird38: ? → +

Updated

3 years ago
Blocks: 1132405
You need to log in before you can comment on or make changes to this bug.