Closed Bug 1163357 Opened 9 years ago Closed 9 years ago

Images won't load after an unknown number are opened during a session, across Windows 8.1, Arch Linux and OS X

Categories

(Firefox :: Untriaged, defect)

37 Branch
x86_64
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 1150089

People

(Reporter: joshuaholjackson, Unassigned)

Details

Attachments

(1 file)

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150420225811

Steps to reproduce:

Browse. image-heavy websites, especially imageboards or image galleries, loading both thumbnails and the full-sized image. It usually takes more than just one page to trigger the problem, so I may be unable to give precise reproduction steps.


Actual results:

After a number of images (I'm not certain, but well over 200) are loaded, Firefox will fail to load new images in either a rendered page or opened in their own tab. Pages and images already opened will be blanked out, and newly opened or refreshed pages and images will seem to be stuck loading, with the throbber on tabs still animating. The issue seems to be resolved when Firefox's process is terminated and started again, or sometimes after 5-10 minutes while still running. After either of these, images can be loaded again until this unknown limit is reached; however, if one waits for the problem to 'fix' itself, images opened in tabs have to be refreshed to render again. Web content cache sizes of 350MB, 1024MB, and Off all produce the same result.


Expected results:

Until Firefox 37, I was able to open as many images as I wanted without any browser issues.
OS: Unspecified → All
Hardware: Unspecified → x86_64
Do you have a link to reproduce the issue regularly?
(In reply to Loic from comment #1)
> Do you have a link to reproduce the issue regularly?

I'll try and find something. I haven't been able to get it to happen with a single page, rather opening several pages or threads on some image-heavy websites.
(In reply to Loic from comment #1)
> Do you have a link to reproduce the issue regularly?

http://forums.somethingawful.com/showthread.php?threadid=3693445&userid=0&perpage=40&pagenumber=6
Nothing blatantly NSFW but might contain mildly suggestive images. I counted 306 img tags, most of which being .gifs.
After opening the page on a fresh profile with Firefox 38 (beta channel), images (both static and animated) start disappearing from other tabs and pages (including FF menus: https://i.imgur.com/lt3kNeb.png).
Firefox 39a (developer edition) with a fresh profile doesn't seem to have the same bug.
Seeing the same issue; depending on image size, Firefox stops loading in any more images after a certain point (50-100). Works in Firefox 36 and Firefox 39a, not in Firefox 37 and 38.
Looks like it got fixed with 38.0.1.
Status: UNCONFIRMED → RESOLVED
Closed: 9 years ago
Resolution: --- → WORKSFORME
Resolution: WORKSFORME → DUPLICATE
You need to log in before you can comment on or make changes to this bug.