bugzilla.mozilla.org has resumed normal operation. Attachments prior to 2014 will be unavailable for a few days. This is tracked in Bug 1475801.
Please report any other irregularities here.

SVG blurred in YouTube's new player controls

RESOLVED INVALID

Status

()

Core
SVG
RESOLVED INVALID
3 years ago
2 years ago

People

(Reporter: yonezpt, Unassigned)

Tracking

52 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8603793 [details]
ss.png

User Agent: Mozilla/5.0 (Windows NT 6.1; WOW64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/42.0.2311.135 Safari/537.36

Steps to reproduce:

Open https://www.youtube.com/testtube and click on "Get the player" button to activate the new YouTube player with SVG controls

Play any video in normal small or tiny size, the controls are detailed as they should. Change to a bigger size or into theater mode and the controls become blurry.

Repeat the same steps in Chrome and the controls never get blurry.

This issue also exists in latest Nightly 40.0a1 (2015-05-09)


Actual results:

The controls became blurry when the player increased its size. See attached image showing a zoomed comparison of the issue.


Expected results:

The controls should not get blurry.
Component: Untriaged → SVG
Product: Firefox → Core
(Reporter)

Comment 1

3 years ago
Further testing seems to confirm that this issue occurs when the player has an odd width value, so this might be a case of bad rendering caused by the half-pixel dilemma
(Reporter)

Comment 2

3 years ago
Confirmed that this issue is being caused by the half-pixel dilemma, will repost in a dedicated issue with clear title and test example.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → INVALID
(Reporter)

Updated

2 years ago
Version: 37 Branch → 52 Branch
You need to log in before you can comment on or make changes to this bug.