Added and Last Modified timestamps are not synced in bookmarks when using sync

RESOLVED DUPLICATE of bug 676563

Status

()

Firefox
Sync
--
enhancement
RESOLVED DUPLICATE of bug 676563
3 years ago
a year ago

People

(Reporter: Johan Angelstam, Unassigned)

Tracking

37 Branch
All
Unspecified
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

3 years ago
Created attachment 8603813 [details]
Firefox bookmarks after sync. The columns "Added" and "Last Modified" are not synchronized.

User Agent: Mozilla/5.0 (Macintosh; Intel Mac OS X 10.7; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

I set up Sync on two computers (A and B) with previous bookmarks to synchronize the bookmarks on each computer with the other.


Actual results:

The bookmarks got synced. However, the columns "Added" and "Last Modified" where not synched. Instead on computer A the original timestamps from computer B where replaced by the current time-stamp and the reverse on computer B with bookmarks from computer A.


Expected results:

The data in "Added" and "Last Modified" should be identical on both computers, i.e. the original timestamps should be synchronized as I have not edited nor added any bookmarks.
(Reporter)

Updated

3 years ago
Component: Untriaged → Sync
Hardware: Unspecified → All

Updated

3 years ago
Priority: -- → P3

Comment 1

2 years ago
Happens to me too.

Updated

2 years ago
Blocks: 621584
Severity: normal → enhancement
Priority: P3 → --

Comment 2

a year ago
I confirm that I can reproduce this behavior on Mozilla Firefox ESR 45.4.0 on Red Hat Enterprise Linux Server release 7.2.

I feel that the severity level should be critical as this behavior is a corruption of user data. The Added and Last Modified fields are important metadata for analysis of user bookmarks. The values should consistently represent the times that bookmarks are added and modified by the user, not the times that the synchronization occurred.
I agree that this is both inaccurate and frustrating. Activity Stream is running into this issue, too: it gets confused on a new device (or a device that just hasn't synced in a while) because it sees all synced bookmarks as new. We're using bug 676563 as the product tracking bug, and expect to work on this in the coming months.
Status: UNCONFIRMED → RESOLVED
Last Resolved: a year ago
Resolution: --- → DUPLICATE
Duplicate of bug: 676563
You need to log in before you can comment on or make changes to this bug.