Closed Bug 1163418 Opened 4 years ago Closed 3 years ago

Intermittent e10s browser_CTP_iframe.js,browser_CTP_nonplugins.js,browser_CTP_resize.js | Uncaught exception - at chrome://mochitests/content/browser/browser/base/content/test/plugins/head.js:106 - Error: Timed out while waiting for a 'load'' event

Categories

(Core :: Plug-ins, defect)

defect
Not set

Tracking

()

RESOLVED FIXED
mozilla50
Tracking Status
e10s + ---
firefox48 --- fixed
firefox49 --- fixed
firefox-esr38 --- unaffected
firefox-esr45 --- wontfix
firefox50 --- fixed

People

(Reporter: philor, Assigned: mrbkap)

References

(Blocks 1 open bug)

Details

(Keywords: intermittent-failure)

Attachments

(3 files, 1 obsolete file)

No description provided.
Blocks: e10s-tests
tracking-e10s: --- → +
Summary: Intermittent e10s browser_CTP_nonplugins.js | Uncaught exception - at chrome://mochitests/content/browser/browser/base/content/test/plugins/head.js:106 - Error: Timed out while waiting for a 'load'' event → Intermittent e10s browser_CTP_iframe.js,browser_CTP_nonplugins.js,browser_CTP_resize.js | Uncaught exception - at chrome://mochitests/content/browser/browser/base/content/test/plugins/head.js:106 - Error: Timed out while waiting for a 'load'' event
Duplicate of this bug: 1178705
Attached patch Patch 1 (obsolete) — Splinter Review
This test had its own version of waitForContentEvent that hadn't be converted to use BrowserTestUtils & friends. In order to preserve the original condition, I split it up into a ContentTask/ContentTaskUtils.waitForEvent.
Attachment #8761846 - Flags: review?(felipc)
Attached patch Patch 2Splinter Review
While I was looking for bugs like this, I found a couple more cases.
Attachment #8761847 - Flags: review?(felipc)
Attached patch Patch 3Splinter Review
These need to wait on an untrusted event. It's also important to capturing for the event, since it doesn't bubble.
Attachment #8761849 - Flags: review?(felipc)
Assignee: nobody → mrbkap
Attached patch Patch 1 (v2)Splinter Review
There was another CPOW hiding in this test.
Attachment #8761846 - Attachment is obsolete: true
Attachment #8761846 - Flags: review?(felipc)
Attachment #8763199 - Flags: review?(felipc)
Attachment #8761847 - Flags: review?(felipc) → review+
Comment on attachment 8761849 [details] [diff] [review]
Patch 3

Review of attachment 8761849 [details] [diff] [review]:
-----------------------------------------------------------------

::: testing/mochitest/BrowserTestUtils/ContentTaskUtils.jsm
@@ +96,5 @@
>     *
>     * @returns {Promise}
>     * @resolves The Event object.
>     */
> +  waitForEvent(subject, eventName, capture, checkFn, wantsUntrusted = false) {

I couldn't find where this new argument is used. The other change in this patch uses the waitForContentEvent function, not waitForEvent.  r+ if I'm missing something obvious
Attachment #8761849 - Flags: review?(felipc) → review+
Attachment #8763199 - Flags: review?(felipc) → review+
(In reply to :Felipe Gomes (needinfo me!) [offline until Jun 24] from comment #25)
> I couldn't find where this new argument is used. The other change in this
> patch uses the waitForContentEvent function, not waitForEvent.  r+ if I'm
> missing something obvious

You're not missing anything. A previous version of my patch did use this function before I simplified it to use waitForContentEvent and I decided to leave this change in as it could be useful to others in the future who do want to listen for untrusted events in a content task. I'm going to check it in as-is.
Pushed by mrbkap@mozilla.com:
https://hg.mozilla.org/integration/mozilla-inbound/rev/5e1af601a50b
Remove use of CPOWs in in browser plugin tests. r=felipe
https://hg.mozilla.org/integration/mozilla-inbound/rev/4d54710a9a96
Remove use of CPOWs in browser_bookmark_titles.js. r=felipe
https://hg.mozilla.org/integration/mozilla-inbound/rev/42753a079c66
Remove use of CPOWs in safebrowsing tests. r=felipe
Whiteboard: [checkin-needed-aurora]
You need to log in before you can comment on or make changes to this bug.