High CPU usage on some websites

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
4 years ago
3 years ago

People

(Reporter: csabi98, Unassigned)

Tracking

37 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

4 years ago
Created attachment 8604004 [details]
FF.png

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:37.0) Gecko/20100101 Firefox/37.0
Build ID: 20150415140819

Steps to reproduce:

Accessed http://www.cel.ro/procesoare/amd/ and some other heavily scripted websites.
I'm using Firefox on Debian Jessie.
Adobe Flash is not allowed on that website.


Actual results:

Visiting certain websites causes FF to use lots of CPU (over 50 % with AMD Athlon II X2 255 at 3.1 GHz).
I usually have more than 50 tabs open and all use below 10 %. When opening some sites, CPU jumps to over 50 %. Closing the relevant tab reduces usage to below 10 %.
I installed AdBlock Plus but without results (enabing/disabling the extension doesn't affect the results).


Expected results:

CPU usage should not change much when visiting any website.
Hi Csaba,

I haven't managed to reproduce this issue on the latest release(43.0.3) nor latest Nightly(46.0a1). The link you provided does not use more than 2%-3% of the CPU.

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:43.0) Gecko/20100101 Firefox/43.0
Build ID: 20151223140742

User Agent: Mozilla/5.0 (X11; Linux x86_64; rv:46.0) Gecko/20100101 Firefox/46.0
Build ID: 20160106030225

Can you please try to reproduce this on the latest release(43.0.3) and latest Nightly(46.0a1) and provide the results? When doing this, please try to reproduce with a new clean Firefox profile, maybe even in safe mode, as some of this issues may be caused by third party installed add-ons or custom settings(https://support.mozilla.org/en-US/kb/troubleshoot-and-diagnose-firefox-problems).

Thanks,
Paul.
Flags: needinfo?(csabi98)
(Reporter)

Comment 2

3 years ago
Hi

The issue disappeared some time ago with a newer version of FF.
I'm using version 42 on Debian Jessie and it's OK.
Thanks!
Flags: needinfo?(csabi98)
Since the reporter didn't reproduced this issue any more on the latest builds, I will mark this issue as RESOLVED WORKSFORME. If you still encounter this problem, please feel free to reopen this bug, or file a new one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.