[Contacts][Pick Activity] "This contact does not have an email address" confirm dialog in pick activity changes to "No contacts in your Contacts list" if an email address is added in the main contacts app

RESOLVED WONTFIX

Status

Firefox OS
Gaia::Contacts
P3
normal
RESOLVED WONTFIX
3 years ago
3 months ago

People

(Reporter: SandKing, Unassigned)

Tracking

unspecified
ARM
Gonk (Firefox OS)

Firefox Tracking Flags

(tracking-b2g:backlog, b2g-v2.2 affected, b2g-master affected)

Details

(Whiteboard: [v2.2-nexus-5-l])

Attachments

(2 attachments)

(Reporter)

Description

3 years ago
Created attachment 8604034 [details]
Bug log: logcat_1521.txt

[1.Description]:
[Nexus 5][v2.2&v3.0][Flame][v2.2&v3.0][Email]After the "This contact does not have an email address" prompt box pops up, update the only contact's informaiton and back to Email, you can find the prompt text is not logical.
See log:"logcat_1521.txt"
See video:"1521.mp4"
Found time: 15:21

[2.Testing Steps]: 
Premise: There only is a contact(without email address) in device.
1. Luanch E-mail and sign in  an account.
2. Compose a new mail.
3. Tap the "+" icon which is behind the recipient bar.
4. Select the only contact.
5. When the "This contact does not have an email address" box pops up, Press Home key,and launch Contact again.
6. Update the contact(EX. add email address).
7. Switch to Email ap from card view. 

[3.Expected Result]: 
7. The prompt words shouldn't be changed.

[4.Actual Result]: 
7. You can see the prompt words was changed to "No contacts in your Contacts list"

[5.Reproduction build]: 
Flame 2.2 build(Affected)
Build ID               20150510002505
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.042512
Firmware Date          Sun May 10 04:25:23 EDT 2015
Bootloader             L1TC000118D0

Flame 3.0 build(Affected)
Build ID               20150510010201
Gaia Revision          5b2a150f6f5d29bddfaac13fcbbf099376f2f275
Gaia Date              2015-05-09 12:34:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/77d92f6d7679
Gecko Version          40.0a1
Device Name            flame
Firmware(Release)      4.4.2
Firmware(Incremental)  eng.cltbld.20150510.045933
Firmware Date          Sun May 10 04:59:44 EDT 2015
Bootloader             L1TC000118D0

Nexus5 2.2 build(Affected)
Build ID               20150510002505
Gaia Revision          528ef60e7cda09ad43478065f5d33bda398fbeb7
Gaia Date              2015-05-08 23:40:58
Gecko Revision         https://hg.mozilla.org/releases/mozilla-b2g37_v2_2/rev/8d04cc085cf5
Gecko Version          37.0
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150510.043050
Firmware Date          Sun May 10 04:31:07 EDT 2015
Bootloader             HHZ12f

Nexus5 3.0 build(Affected)
Build ID               20150510010201
Gaia Revision          5b2a150f6f5d29bddfaac13fcbbf099376f2f275
Gaia Date              2015-05-09 12:34:41
Gecko Revision         https://hg.mozilla.org/mozilla-central/rev/77d92f6d7679
Gecko Version          40.0a1
Device Name            hammerhead
Firmware(Release)      5.1
Firmware(Incremental)  eng.cltbld.20150510.044405
Firmware Date          Sun May 10 04:44:24 EDT 2015
Bootloader             HHZ12f

[6.Reproduction Frequency]: 
Always Recurrence,5/5

[7.TCID]: 
Free Test

[8. Note]:
If there is more than one contact in device, it will be unable to reproduce this issue.
(Reporter)

Comment 1

3 years ago
Created attachment 8604036 [details]
Bug video: 1521.MP4
(Reporter)

Updated

3 years ago
status-b2g-v2.2: --- → affected
status-b2g-master: --- → affected
Moving to the contacts component since all of this logic exists in the contacts app.  (The rocketbar/statusbar color changes help make this non-obvious change somewhat more obvious since the statusbar is orange in email/productivity and cyan in contacts/communications.)
Summary: [Email]After you updated contact's informaiton and back to Email, you can find the prompt text is not logical. → [Contacts][Pick Activity] "This contact does not have an email address" confirm dialog in pick activity changes to "No contacts in your Contacts list" if an email address is added in the main contacts app
Error message changed, weird behaviour although it looks edgy. Minor, suggest to backlog.
Step 7. You can see the prompt words was changed to "No contacts in your Contacts list"
Flags: needinfo?(whuang)
[Tracking Requested - why for this release]:
tracking-b2g: --- → backlog
Component: Gaia::E-Mail → Gaia::Contacts
Flags: needinfo?(whuang)
Per comms triage.
Priority: -- → P3

Comment 6

3 months ago
Firefox OS is not being worked on
Status: NEW → RESOLVED
Last Resolved: 3 months ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.