[aries-l] Porting Bluetooth for aries-l

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
4 years ago
4 years ago

People

(Reporter: seinlin, Assigned: shawnjohnjr)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(3 attachments, 1 obsolete attachment)

(Reporter)

Description

4 years ago
E/bluetoothd( 3026): hw_get_module failed: Unknown error -2
I/GeckoBluetooth(  325): OnError: BluetoothInterface::Init failed: 1
(Reporter)

Updated

4 years ago
Component: Bluetooth → GonkIntegration
(Reporter)

Updated

4 years ago
Blocks: 1163561
1. Build config is missing in external/bluetooth/bluedroid, we should add build targets in BoardConfig.mk. I will open an another bug.
2. /system/vendor/lib/libbt-vendor.so vendor library is missing. We should have backup script to install this library.
Regarding item 2, seinlin would you help to update the script?
Flags: needinfo?(kli)
Assignee: nobody → shuang
Summary: [aries-l] Bluetooth does not work in aries-l → [aries-l] Porting Bluetooth for aries-l
Created attachment 8606144 [details]
Bug 1163552 - Build bluedroid stack for aries-l
Attachment #8606144 - Flags: review?(kli)
Attachment #8606144 - Attachment is obsolete: true
Attachment #8606144 - Flags: review?(kli)
(Reporter)

Comment 5

4 years ago
Shawn, Thanks! I merged your PR into my wip. Let's leave this bug open till every thing is merged into mozilla-b2g.
Flags: needinfo?(kli)
(Reporter)

Comment 6

4 years ago
Shawn, as per bug 1163550 comment 31, do you have any idea?
Flags: needinfo?(shuang)
(In reply to Kai-Zhen Li [:kli][:seinlin] from comment #6)
> Shawn, as per bug 1163550 comment 31, do you have any idea?

Not sure if they have any of proprietary code. But if they confirmed we can build ourselves, i think we can simply fetch libbt from git and build it directly.
Flags: needinfo?(shuang)
(Reporter)

Comment 8

4 years ago
Shawn, Could you help to check the error as in bug 1163550 comment 56? Thanks!
Per bug 1163550 comment 70, when pairing I fetched snoop log and I did not find any request to pair.


748	Command	0x0402	Inquiry_Cancel						0	4	 00:00:00.326142	2015/6/10 上午 03:52:03.964965	
	749	Event	0x0402	Inquiry_Cancel	Command Complete	Success				4	7	 00:00:00.005592	2015/6/10 上午 03:52:03.970557	
	750	Command	0x200c	HCI_LE_Set_Scan_Enable						2	6	 00:00:00.000294	2015/6/10 上午 03:52:03.970851	
	751	Event	0x200c	HCI_LE_Set_Scan_Enable	Command Complete	Success				4	7	 00:00:00.002928	2015/6/10 上午 03:52:03.973779	
	752	Command	0x200b	HCI_LE_Set_Scan_Parameters						7	11	 00:00:00.000170	2015/6/10 上午 03:52:03.973949	
	753	Event	0x200b	HCI_LE_Set_Scan_Parameters	Command Complete	Success				4	7	 00:00:00.002365	2015/6/10 上午 03:52:03.976314	
	754	Command	0x0c12	Delete_Stored_Link_Key						7	11	 00:00:00.000150	2015/6/10 上午 03:52:03.976464	
	755	Event	0x0c12	Delete_Stored_Link_Key	Command Complete	Success				6	9	 00:00:00.000574	2015/6/10 上午 03:52:03.977038	
	756	Command	0x0419	Remote_Name_Request						10	14	 00:00:00.000148	2015/6/10 上午 03:52:03.977186	
	757	Event	0x0419	Remote_Name_Request	Command Status	Success				4	7	 00:00:00.000619	2015/6/10 上午 03:52:03.977805	
	758	Command	0x200c	HCI_LE_Set_Scan_Enable						2	6	 00:00:07.702901	2015/6/10 上午 03:52:11.680706	
	759	Event	0x200c	HCI_LE_Set_Scan_Enable	Command Complete	Command Disallowed				4	7	 00:00:00.006789	2015/6/10 上午 03:52:11.687495	
	760	Command	0x200b	HCI_LE_Set_Scan_Parameters						7	11	 00:00:00.001176	2015/6/10 上午 03:52:11.688671	
	761	Event	0x200b	HCI_LE_Set_Scan_Parameters	Command Complete	Success				4	7	 00:00:00.002557	2015/6/10 上午 03:52:11.691228
06-10 11:50:11.667 E/BTLD    ( 1451): ######################################################################
06-10 11:50:11.667 E/BTLD    ( 1451): #
06-10 11:50:11.667 E/BTLD    ( 1451): # WARNING : BTU HCI(id=0) command timeout. opcode=0x200c
06-10 11:50:11.667 E/BTLD    ( 1451): #
06-10 11:50:11.667 E/BTLD    ( 1451): ######################################################################
06-10 11:50:11.667 W/bt-hci  ( 1451): HCI Cmd timeout counter 1
06-10 11:50:11.667 D/bt-btif ( 1451):  bta_sys_hw_btm_cback was called with parameter: 2
Hi :seinlin
Do you know is there any other chance we can verify z3c bluetooth function for L?
Flags: needinfo?(seinlin.maung+bugs)
Created attachment 8617767 [details]
logcat_aosp_pairingtimeout.txt

The same problem I can observe on aosp-lollipop.

04-27 18:34:19.986 I/bt-btm  ( 3189): btm_sec_pairing_timeout()  State: 1   Flags: 1
04-27 18:34:19.986 W/bt-btm  ( 3189): btm_sec_pairing_timeout() not processed state: 1
(Reporter)

Comment 15

4 years ago
(In reply to Shawn Huang [:shawnjohnjr] from comment #13)
> Hi :seinlin
> Do you know is there any other chance we can verify z3c bluetooth function
> for L?

Do you mean aosp L? If so sony developer site provide enough information to build an aosp ROM.

http://developer.sonymobile.com/knowledge-base/open-source/open-devices/aosp-build-instructions/how-to-build-aosp-lollipop-for-unlocked-xperia-devices/
Flags: needinfo?(seinlin.maung+bugs)
(In reply to Kai-Zhen Li [:kli][:seinlin] from comment #15)
> (In reply to Shawn Huang [:shawnjohnjr] from comment #13)
> > Hi :seinlin
> > Do you know is there any other chance we can verify z3c bluetooth function
> > for L?
> 
> Do you mean aosp L? If so sony developer site provide enough information to
> build an aosp ROM.
> 
> http://developer.sonymobile.com/knowledge-base/open-source/open-devices/aosp-
> build-instructions/how-to-build-aosp-lollipop-for-unlocked-xperia-devices/

Nope. I mean official build from sony. It looks like official z3c Android 5.0 writes into different proc nodes for LPM mode, and it seems that I can't reference official z3c Android 5.0 build now, it's different from z3c aosp lollipop codebase (v5.1).
Status: NEW → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.