Api request to get premium apps is failing with 500 error

RESOLVED WONTFIX

Status

Marketplace
API
P4
minor
RESOLVED WONTFIX
3 years ago
3 years ago

People

(Reporter: Madalin Cotetiu, Unassigned)

Tracking

Avenir
2015-05-12
Points:
---

Details

(URL)

(Reporter)

Description

3 years ago
Steps to reproduce:
1. Perform the following request:
GET 
https://marketplace.allizom.org/api/v2/apps/search/?premium_types=premium

Expected results:
A list of paid apps is returned.

Actual results:
The request fails with 500
{"detail":"Internal Server Error"}

Notes/Issues
Verified in FF40(Win7) Issue can only be reproduced in mp-stage.
Sentry: http://sentry.dmz.phx1.mozilla.com/marketplace-stage/marketplace-stage/group/27660/

Doesn't look like a new problem. We fail on a paid app because there was an error retrieving the associated payment account. We have some code to handle this, and it is this code that is causing the error.

Could be caused by https://bugzilla.mozilla.org/show_bug.cgi?id=1156864 if there is still some payment accounts referencing boku ? Not sure.
Note: this does not affect consumer pages, because fireplace API never exposes the field that is causing the error.
Data issue on Stage.
Severity: normal → minor
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Priority: -- → P4
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.